Cyberduck Mountain Duck CLI

#8729 closed defect (fixed)

Location of Filezilla XML changed no auto import

Reported by: jamesicv Owned by: dkocher
Priority: normal Milestone: 4.7
Component: core Version: 4.6.5
Severity: normal Keywords: filezilla, import
Cc: Architecture: Intel
Platform:

Description (last modified by dkocher)

Apparently the location of Filezilla files changed in the last two years. On my mac, OSX 10.10.1, the file is not at ~./filezilla

It's now at ~/.config/filezilla

I cannot import at this point. Is there some workaround? Thanks

Change History (7)

comment:1 Changed on Apr 6, 2015 at 7:12:51 PM by dkocher

  • Milestone set to 4.7
  • Owner set to dkocher
  • Priority changed from high to normal
  • Status changed from new to assigned

comment:2 Changed on Apr 6, 2015 at 7:15:42 PM by dkocher

You can set the hidden preference bookmark.import.filezilla.location which defaults to ~/.filezilla/sitemanager.xml.

comment:3 follow-up: Changed on Apr 7, 2015 at 8:19:12 AM by dkocher

I cannot reproduce FileZilla to save its configuration in ~/.config.

comment:4 Changed on Apr 7, 2015 at 8:26:41 AM by dkocher

  • Description modified (diff)

comment:5 in reply to: ↑ 3 Changed on Apr 7, 2015 at 8:27:58 AM by dkocher

Replying to dkocher:

I cannot reproduce FileZilla to save its configuration in ~/.config.

Removing the configuration files from .~/filezilla will initialize ~/.config/filezilla.

Last edited on Apr 7, 2015 at 8:29:03 AM by dkocher (previous) (diff)

comment:6 Changed on Apr 7, 2015 at 8:33:47 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r17246.

comment:7 Changed on Apr 7, 2015 at 9:51:24 PM by jamesicv

Thanks. CAn you help me run that setting? Im not clear on the Syntax.

It does not seem to take effect when I :

thismac-iMac:~thismac$ defaults write ch.sudo.cyberduck bookmark.import.filezilla.location ~/.config/filezilla/sitemanager.xml

New installs or updates to Filezilla appear to move the files. I did not move them manually.. I found info on it here. That's how I found the file after looking where it used to be: https://forum.filezilla-project.org/viewtopic.php?t=34371

Last edited on Apr 8, 2015 at 7:13:02 AM by dkocher (previous) (diff)
Note: See TracTickets for help on using tickets.
swiss made software