Cyberduck Mountain Duck CLI

#8732 closed defect (duplicate)

#8597 Not completely fixed - "change of username or service not allowed"

Reported by: matthijs zwinderman Owned by: dkocher
Priority: normal Milestone: 4.7
Component: sftp Version: 4.6.5
Severity: major Keywords: ssh
Cc: Architecture:
Platform: Mac OS X 10.10

Description

After you fixed #8597, I could login for a little while on my SSH, it was flaky but it worked. Now I again get the same message:

Change of username or service not allowed: (<<username>>,ssh-connection) -> (,ssh-connection). Please contact your web hosting service provider for assistance.

I have private/public key + google authenticator. With the terminal-ssh on OSX this works fine, but not with Cyberduck.

I fill in my username in the "open connection" dialog, check "use public key authentication". Click connect and then fill in the passphrase to the key (here the username is remembered). Clicking 'Login' again I now get a "partial authentication success" dialog, where the username is empty and I have to fill in a password (which is weird, since I don't get this for the terminal-ssh). I tried entering the verification code (from google authenticator), but it doesn't work.

/ Since #8597 I've removed the need for password during login, now it's only key- and authenticator

Change History (1)

comment:1 Changed on Apr 8, 2015 at 8:03:30 PM by dkocher

  • Milestone set to 4.7
  • Resolution set to duplicate
  • Status changed from new to closed

Duplcate for #8597. Please update to the latest snapshot build available.

Note: See TracTickets for help on using tickets.
swiss made software