Cyberduck Mountain Duck CLI

#8744 closed defect (duplicate)

Crashes when uploading files

Reported by: jdannD02 Owned by: dkocher
Priority: high Milestone: 4.7
Component: webdav Version: 4.6.5
Severity: major Keywords: Crash, upload
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by dkocher)

Cyberduck was working great until a couple of days ago. Now when I try to upload files it freezes for 1-2 minutes and then crashes.

Below is the error info that I receive:

Problem signature:
  Problem Event Name:	CLR20r3
  Problem Signature 01:	Cyberduck.exe
  Problem Signature 02:	4.6.5.17000
  Problem Signature 03:	54ede92b
  Problem Signature 04:	Cyberduck
  Problem Signature 05:	4.6.5.17000
  Problem Signature 06:	54ede92b
  Problem Signature 07:	15d0
  Problem Signature 08:	2de
  Problem Signature 09:	PSZQOADHX1U5ZAHBHOHGHLDGIY4QIXHX
  OS Version:	6.1.7601.2.1.0.256.4
  Locale ID:	1033
  Additional Information 1:	0a9e
  Additional Information 2:	0a9e372d3b4ad19135b953a78882e789
  Additional Information 3:	0a9e
  Additional Information 4:	0a9e372d3b4ad19135b953a78882e789

Attachments (1)

cyberduck.log (677.4 KB) - added by jdannD02 on Apr 14, 2015 at 5:11:51 PM.

Download all attachments as: .zip

Change History (6)

comment:1 Changed on Apr 14, 2015 at 11:03:52 AM by dkocher

  • Description modified (diff)
  • Milestone set to 4.7
  • Status changed from new to assigned
  • Summary changed from Cyberduck crashes when uploading files to Crashes when uploading files

Please attach the file cyberduck.log in the application support directory.

Changed on Apr 14, 2015 at 5:11:51 PM by jdannD02

comment:2 Changed on Apr 14, 2015 at 8:40:11 PM by dkocher

2015-04-13 14:20:08,556 [Thread-0] ERROR AsyncController - Unhandled exception during invoke
cli.StructureMap.StructureMapException: StructureMap Exception Code:  207
Internal exception while creating Instance '07468003-8fb0-4a94-8595-6cece36f51fe' of PluginType Ch.Cyberduck.Ui.Controller.IProgressView.  Check the inner exception for more details.
	at cli.StructureMap.Pipeline.ConstructorInstance.Build(Unknown Source)
	at cli.StructureMap.Pipeline.ConstructorInstance.build(Unknown Source)
	at cli.StructureMap.Pipeline.SmartInstance$$00601.build(Unknown Source)
	at cli.StructureMap.Pipeline.Instance.createRawObject(Unknown Source)
	at cli.StructureMap.Pipeline.Instance.Build(Unknown Source)
	at cli.StructureMap.Pipeline.ObjectBuilder.Resolve(Unknown Source)
	at cli.StructureMap.BuildSession.CreateInstance(Unknown Source)
	at cli.StructureMap.BuildSession$$$003C$$003Ec__DisplayClass3.<.ctor>b__1(Unknown Source)
	at cli.StructureMap.BuildSession.CreateInstance(Unknown Source)
	at cli.StructureMap.Container.GetInstance(Unknown Source)
	at cli.StructureMap.ObjectFactory.GetInstance(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.ProgressController.<init>(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.TransferController$$$003C$$003Ec__DisplayClass3.<collectionItemAdded>b__2(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.Threading.SimpleDefaultMainAction.run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.AsyncController.invoke(Unknown Source)
	at IKVM.Internal.ExceptionHelper.toString(Unknown Source)
	at java.lang.Throwable.toString(map.xml:1315)
	at java.lang.Object.toString(map.xml)
	at java.lang.StringHelper.valueOf(StringHelper.java:2390)
	at java.io.PrintWriter.println(PrintWriter.java:754)
	at java.lang.ThrowableHelper$WrappedPrintWriter.println(ThrowableHelper.java:343)
	at java.lang.ThrowableHelper.printStackTrace(ThrowableHelper.java:231)
	at java.lang.ThrowableHelper.printStackTrace(ThrowableHelper.java:300)
	at java.lang.Throwable.printStackTrace(map.xml:1188)
	at org.apache.log4j.DefaultThrowableRenderer.render(DefaultThrowableRenderer.java:60)
	at org.apache.log4j.spi.ThrowableInformation.getThrowableStrRep(ThrowableInformation.java:87)
	at org.apache.log4j.spi.LoggingEvent.getThrowableStrRep(LoggingEvent.java:413)
	at org.apache.log4j.WriterAppender.subAppend(WriterAppender.java:313)
	at org.apache.log4j.RollingFileAppender.subAppend(RollingFileAppender.java:277)
	at org.apache.log4j.WriterAppender.append(WriterAppender.java:163)
	at org.apache.log4j.AppenderSkeleton.doAppend(AppenderSkeleton.java:252)
	at org.apache.log4j.helpers.AppenderAttachableImpl.appendLoopOnAppenders(AppenderAttachableImpl.java:64)
	at org.apache.log4j.Category.callAppenders(Category.java:206)
	at org.apache.log4j.Category.forcedLog(Category.java:392)
	at org.apache.log4j.Category.error(Category.java:324)
	at cli.Ch.Cyberduck.Ui.Controller.AsyncController.invoke(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.WindowController.invoke(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.TransferController.collectionItemAdded(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.TransferController.<init>(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.TransferController.get_Instance(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.BrowserController.transfer(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.BrowserController.transfer(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.BrowserController.transfer(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.BrowserController.View_Upload(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Winforms.BrowserForm.<ConfigureFileCommands>b__e6(Unknown Source)
	at cli.System.Windows.Forms.ToolStripItem.RaiseEvent(Unknown Source)
	at cli.System.Windows.Forms.ToolStripMenuItem.OnClick(Unknown Source)
	at cli.System.Windows.Forms.ToolStripItem.HandleClick(Unknown Source)
	at cli.System.Windows.Forms.ToolStripItem.HandleMouseUp(Unknown Source)
	at cli.System.Windows.Forms.ToolStripItem.FireEventInteractive(Unknown Source)
	at cli.System.Windows.Forms.ToolStripItem.FireEvent(Unknown Source)
	at cli.System.Windows.Forms.ToolStrip.OnMouseUp(Unknown Source)
	at cli.System.Windows.Forms.ToolStripDropDown.OnMouseUp(Unknown Source)
	at cli.System.Windows.Forms.Control.WmMouseUp(Unknown Source)
	at cli.System.Windows.Forms.Control.WndProc(Unknown Source)
	at cli.System.Windows.Forms.ScrollableControl.WndProc(Unknown Source)
	at cli.System.Windows.Forms.ToolStrip.WndProc(Unknown Source)
	at cli.System.Windows.Forms.ToolStripDropDown.WndProc(Unknown Source)
	at cli.System.Windows.Forms.Control$ControlNativeWindow.OnMessage(Unknown Source)
	at cli.System.Windows.Forms.Control$ControlNativeWindow.WndProc(Unknown Source)
	at cli.System.Windows.Forms.NativeWindow.Callback(Unknown Source)
	at cli.System.Windows.Forms.UnsafeNativeMethods.DispatchMessageW(Unknown Source)
	at cli.System.Windows.Forms.Application$ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(Unknown Source)
	at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoopInner(Unknown Source)
	at cli.System.Windows.Forms.Application$ThreadContext.RunMessageLoop(Unknown Source)
	at cli.System.Windows.Forms.Application.Run(Unknown Source)
	at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.OnRun(Unknown Source)
	at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.DoApplicationModel(Unknown Source)
	at cli.Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplicationBase.Run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.Run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.Run(Unknown Source)
	at cli.Ch.Cyberduck.Ui.Controller.MainController.Main(Unknown Source)
Caused by: cli.System.ComponentModel.Win32Exception: Error creating window handle.

comment:3 Changed on Apr 14, 2015 at 8:41:12 PM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate for #6550.

comment:4 follow-up: Changed on Apr 14, 2015 at 8:42:16 PM by dkocher

Please restart Windows and try again.

comment:5 in reply to: ↑ 4 Changed on Apr 15, 2015 at 12:21:52 AM by jdannD02

Replying to dkocher:

Please restart Windows and try again.

Restart did not fix the issue.

Note: See TracTickets for help on using tickets.
swiss made software