Cyberduck Mountain Duck CLI

#8750 closed defect (worksforme)

Renaming file fails when reading access control list

Reported by: rugbyball Owned by: dkocher
Priority: high Milestone: 4.7
Component: s3 Version: 4.6.5
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description

I have an s3 bucket that allows all permissions to the bucket. It requires Server Side Encryption (SSE) to be turned on in the options of Cyberduck. If you try to rename a file it fails. However if I use Cloudberry's Explorer for S3 using same credentials with SSE turned on in Cloudberry app I am able to rename files.

This seems to be a bug in Cyberduck

I am using Cyberduck version: v. 4.6.5. (17000)

Change History (6)

comment:1 Changed on Apr 16, 2015 at 5:13:28 PM by dkocher

Please post the transcript from the log drawer (⌘-L).

comment:2 Changed on Apr 16, 2015 at 5:14:10 PM by dkocher

  • Milestone set to 4.7

comment:3 Changed on Apr 16, 2015 at 5:49:09 PM by rugbyball

I removed the reference to the URL/S3 Bucket in transcript, I also removed Access key and Secret key info from transcript. Don't want to place that info public. Of note though, you will see a line below that calls out that the secret key was different than the rest. I noticed this as I was removing that information from transcript.

GET /webinar%2Ftest_file_03.txt?acl HTTP/1.1
Date: Thu, 16 Apr 2015 17:31:14 GMT
Authorization: AWS (Removed Access Key & Secret Key)
Host: download.(Removed Website).com.s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.6.5 (17000) (Windows 7/6.1) (x86)
GET /webinar%2Ftest_file_03.txt?acl HTTP/1.1
Date: Thu, 16 Apr 2015 17:31:14 GMT
Authorization: AWS (Removed Access Key & Secret Key)
Host: download.(Removed Website).com.s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.6.5 (17000) (Windows 7/6.1) (x86)
HTTP/1.1 404 Not Found
x-amz-request-id: ACE9D2908DED2C95
x-amz-id-2: eT/8WZGeu3zhT9EtSSjM+D1IKKMp7rJkmX2bq16TBRqHWrdIxofVSuoW8HJD0XEOFGBSZGT/Dc8=
Content-Type: application/xml
Transfer-Encoding: chunked
Date: Thu, 16 Apr 2015 17:31:28 GMT
Server: AmazonS3
GET /?delimiter=%2F&max-keys=1000&prefix=webinar%2F HTTP/1.1
Date: Thu, 16 Apr 2015 17:31:31 GMT
Authorization: AWS (Removed Access Key & Secret Key) // * Note of difference -Access Key on this line was same as others, HOWEVER secret Key was different.//
Host: download.(Removed Website).com.s3.amazonaws.com:443
Connection: Keep-Alive
User-Agent: Cyberduck/4.6.5 (17000) (Windows 7/6.1) (x86)
HTTP/1.1 200 OK
x-amz-id-2: sR+XGaKbtgxKLWGXCLJsuaDQV0vyoBW4OiV7Wor1dEKxl1yB7PmIOY+60SSirt+NXz8Inn8XSE4=
x-amz-request-id: 557A92AEFEA919D6
Date: Thu, 16 Apr 2015 17:31:32 GMT
Content-Type: application/xml
Transfer-Encoding: chunked
Server: AmazonS3
Last edited on Apr 17, 2015 at 7:18:46 AM by dkocher (previous) (diff)

comment:4 Changed on Apr 17, 2015 at 7:19:37 AM by dkocher

The different authorization header is expected as it is derived from the access credentials.

comment:5 Changed on Apr 17, 2015 at 7:46:35 AM by dkocher

  • Summary changed from S3 Bucket renaming files fails to Renaming file fails when reading access control list

Added test in r17318. We cannot reproduce this issue. What is the error message displayed?

comment:6 Changed on Apr 17, 2015 at 7:50:16 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Please make sure you have READ_ACP or FULL_CONTROL permission for the object to move.

Note: See TracTickets for help on using tickets.
swiss made software