Cyberduck Mountain Duck CLI

#8767 closed defect (worksforme)

Application bundle has broken signature

Reported by: rtempchin Owned by:
Priority: highest Milestone:
Component: core Version: 4.7
Severity: blocker Keywords: damaged
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

On a Macbook Pro with the a fresh install of the latest update of Yosemite (10.10.3) I downloaded Cyberduck 4.7 from the website in Chrome using this link: https://update.cyberduck.io/Cyberduck-4.7.zip

It unzips fine, I drag the app to "Applications" and double-click to open it. A dialog pops up saying:

"Cyberduck" is damaged and can't be opened. You should move it to the Trash.

I deleted it and retried several times with the same results. Cyberduck has never been installed on this system before.

Change History (5)

comment:1 Changed on Apr 27, 2015 at 7:46:55 AM by dkocher

  • Summary changed from Cyberduck 4.7 is damaged and can't be opened. to Application bundle has broken signature

I cannot reproduce the issue.

comment:2 Changed on Apr 27, 2015 at 7:49:09 AM by dkocher

Can you run codesign -d -r- --deep-verify /Applications/Cyberduck.app in a Terminal.app window.

comment:3 Changed on Apr 27, 2015 at 1:06:33 PM by rtempchin

Thanks for taking a look. I ran:

codesign -d -r- --deep-verify /Applications/Cyberduck.app

Result:

Executable=/Applications/Cyberduck.app/Contents/MacOS/Cyberduck
Nested=Library/Spotlight/Cyberduck Spotlight Importer.mdimporter
Nested=Frameworks/libLaunchServicesApplicationFinder.dylib
Nested=Frameworks/libDiagnostics.dylib
Nested=MacOS/Runtime.jre
Nested=Frameworks/libQuickLook.dylib
Nested=Frameworks/libIOKitSleepPreventer.dylib
Nested=Frameworks/libProxy.dylib
Nested=Frameworks/libFoundationProgressService.dylib
Nested=Frameworks/libjnidispatch.dylib
Nested=Frameworks/libjdns_sd.dylib
Nested=Frameworks/libLaunchServicesQuarantineService.dylib
Nested=Frameworks/libLaunchServicesFileDescriptor.dylib
Nested=Frameworks/libLaunchServicesSchemeHandler.dylib
Nested=Frameworks/libKeychain.dylib
Nested=Frameworks/Sparkle.framework
Nested=Frameworks/libLocal.dylib
Nested=Frameworks/librococoa.dylib
designated => identifier "ch.sudo.cyberduck" and (anchor apple generic and (certificate leaf[field.1.2.840.113635.100.6.1.9] /* exists */ or certificate 1[field.1.2.840.113635.100.6.2.6] /* exists */ and certificate leaf[field.1.2.840.113635.100.6.1.13] /* exists */ and certificate leaf[subject.OU] = G69SCX94XU) or certificate root = H"a1fb64aab7a4441436d50b91f310bf8c3dafc22c")

comment:4 Changed on May 1, 2015 at 8:45:55 AM by dkocher

The signature verification looks just fine. Not sure why Gatekeeper still complains.

comment:5 Changed on May 4, 2015 at 8:35:03 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software