Cyberduck Mountain Duck CLI

#8777 closed defect (fixed)

Repeated failures when listing directory fails due to character encoding mismatch

Reported by: ftptotal Owned by: Ich
Priority: normal Milestone: 4.7.1
Component: ftp Version: 4.7
Severity: critical Keywords: text encoding proFTPd broadcasting
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

Hi. I have encountered the following:

  1. On the server the rock solid proFTPd operates as FTP-Server.
  1. A folder exists, that has a certain text encoding.
  1. Cyberduck will list the folder name with wrong text encoding ( "?" within text string)
  1. On cklicking on that folder CD displays error: "Anzeigen des Ordners "…" fehlgeschlagen. 550 /… Datei oder Verzeichnis nicht gefunden…
  1. Cyberduck will remain in an infinite loop. "Cancel" does not cancel the process.
  1. Cyberduck has to be force quit.
  1. Cyberduck does not set text encoding according to proFTPd's encoding broadcasting ?
  1. Panic Software's Transmit handles the folder without error.
  1. FileZilla doesn't list the folder at all. This might be due to a to be changed setting.
  1. WebFTP lists the folder without problems and it can be operated on it.

Attachments (1)

Bildschirmfoto 2015-04-27 um 13.28.26.png (37.1 KB) - added by ftptotal on Apr 29, 2015 at 2:03:46 PM.

Download all attachments as: .zip

Change History (8)

comment:1 follow-up: Changed on May 1, 2015 at 8:21:27 AM by dkocher

Please post the transcript from the log drawer (⌘-L).

comment:2 Changed on May 1, 2015 at 8:22:27 AM by dkocher

Change the Encoding setting in the bookmark to ISO-8559-1. Refer to Special characters such as Umlaute.

comment:3 Changed on May 1, 2015 at 8:24:40 AM by dkocher

  • Component changed from core to ftp
  • Milestone set to 4.8
  • Summary changed from Infinite Lopp if directory has differing text coding / force quit necessary / text coding info of proFTPd as FTP-Server not interpreted to Repeated failures when listing directory fails due to character encoding mismatch

comment:4 follow-up: Changed on May 1, 2015 at 8:25:19 AM by dkocher

I cannot reproduce the repeated display of the failure message upon an error changing the working directory to a non-readable folder. Are you running version 4.7?

comment:5 in reply to: ↑ 1 Changed on May 1, 2015 at 1:40:28 PM by ftptotal

Replying to dkocher:

Please post the transcript from the log drawer (⌘-L).

Unfortunately the offending folder has been deleted. I did not save the connection log when the offending folder was present.

comment:6 in reply to: ↑ 4 Changed on May 1, 2015 at 1:41:56 PM by ftptotal

Replying to dkocher:

I cannot reproduce the repeated display of the failure message upon an error changing the working directory to a non-readable folder. Are you running version 4.7?

This is Vesion 4.7 Build 17432

comment:7 Changed on May 19, 2015 at 12:31:43 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r17536.

Note: See TracTickets for help on using tickets.
swiss made software