Cyberduck Mountain Duck CLI

#8786 closed defect (worksforme)

Does not set permissions on directories when applying recursively

Reported by: amedeomantica Owned by: dkocher
Priority: normal Milestone: 4.7.1
Component: sftp Version: 4.7
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.10

Description

Hi, When trying to set permissions recursively, permissions are successfully applied to all files in the tree ( even files within folders and subfolders ), but folders itself appear to be skipped. This happens for sure in SFTP (SSH)

Change History (11)

comment:1 Changed on May 1, 2015 at 5:00:39 PM by dkocher

  • Summary changed from Cyberduck fails to set permissions on directories when applying recursively to Does not set permissions on directories when applying recursively

comment:2 Changed on May 2, 2015 at 6:40:21 AM by dkocher

  • Component changed from core to sftp
  • Milestone set to 4.8
  • Owner set to dkocher
  • Priority changed from high to normal
  • Severity changed from major to normal
  • Status changed from new to assigned

comment:3 Changed on May 2, 2015 at 6:41:59 AM by dkocher

Add test in r17470.

comment:4 Changed on May 2, 2015 at 6:46:40 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

We cannot reproduce this failure. We do make sure to retain the executable bit on directories and will not remove it even when Execute is unchecked.

comment:5 Changed on May 2, 2015 at 9:44:14 AM by amedeomantica

Hi, When I try to set 775 to an entire tree where there are subfolders that don't have execute bit set on "other" they remain unset. I mean if some subfolders have 774 they would not be set to 775, they remain on 774, while the files inside gets 775.

Amedeo

comment:6 Changed on May 2, 2015 at 9:45:10 AM by amedeomantica

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 follow-up: Changed on May 2, 2015 at 9:50:21 AM by amedeomantica

one more thing, I downloaded the source ( I'm a software developer too ) and I see that cyberduck is very well designed, with a core in Java and UI in native language based on platform. I found the Java classes who are responsible to set permissions. However I was unable to realize how to make it run in development, could you give me some instructions ? Thank you so much

ps: I have a paid license under name (amedeo@…)

comment:8 in reply to: ↑ 7 Changed on May 2, 2015 at 5:57:35 PM by dkocher

Replying to amedeomantica:

one more thing, I downloaded the source ( I'm a software developer too ) and I see that cyberduck is very well designed, with a core in Java and UI in native language based on platform. I found the Java classes who are responsible to set permissions. However I was unable to realize how to make it run in development, could you give me some instructions ? Thank you so much

ps: I have a paid license under name (amedeo@…)

There is some help for requirements in trunk/README.txt. Run ant to build.

comment:9 Changed on May 2, 2015 at 5:59:04 PM by dkocher

  • Status changed from reopened to new

comment:10 Changed on May 7, 2015 at 8:09:42 AM by dkocher

#8808 closed as duplicate.

comment:11 Changed on May 22, 2015 at 2:34:58 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Add test in r17632.

Note: See TracTickets for help on using tickets.
swiss made software