Cyberduck Mountain Duck CLI

#8787 closed enhancement (worksforme)

Amazon S3 default ACLs?

Reported by: rjungemann Owned by:
Priority: normal Milestone:
Component: s3 Version: 4.7
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Hello,

I am a longtime user of Cyberduck and I recently purchased it in the Mac Store.

I use the S3 functionality the most to administrate my friend's webcomic. However, the ACLs default to admins only being able to read and write, whereas I would like it to default to everyone being able to read the files as well. Is there a way to do this?

The problem is that if I make a mistake with the ACLs and the files get cached by Cloudfront, then I have to wait for Cloudfront to update before people can see the images that I've stored.

Thanks!

Change History (2)

comment:1 Changed on May 2, 2015 at 6:30:17 AM by dkocher

  • Component changed from core to s3
  • Resolution set to worksforme
  • Status changed from new to closed

Please refer to Default ACLs.

comment:2 Changed on May 2, 2015 at 6:38:16 AM by rjungemann

Thank you so much, this will save me so much time and error!

Note: See TracTickets for help on using tickets.
swiss made software