Cyberduck Mountain Duck CLI

#8814 closed defect (fixed)

Access denied failure downloading folder

Reported by: robmclear Owned by: dkocher
Priority: normal Milestone: 4.7.1
Component: s3 Version: 4.7
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

I have a series of S3 buckets which are serving as storage for Amazon EC2 Instances. Each bucket is connected to the EC2 instance using s3fs. The file structure in the bucket as created by s3fs appears as a zero-byte file (named 301 for instance) followed by a folder also named 301. So for every folder there is also an identically named 0B file listed in S3.

I need to be able to download the entire contents of the S3 bucket without delving into the thousands of folders and subfolders. I had hoped that Cyberduck would accomplish this based on my reading of its capabilities. However the software fails when downloading; it presents an error message "Access Denied: Cannot create folder /Users/mclearr/Desktop/Aquavet Bulk Download/10/13. Please contact your web hosting service provider for assistance."

I am using root credentials for S3 with full access to all buckets when logging in via Cyberduck.

Thanks in advance for your help.

-Rob McLear

Attachments (1)

Screenshot 2015-05-09 21.30.35.png (128.2 KB) - added by robmclear on May 10, 2015 at 1:31:09 AM.

Download all attachments as: .zip

Change History (15)

comment:1 Changed on May 10, 2015 at 7:24:21 AM by dkocher

  • Component changed from core to s3
  • Milestone set to 4.8
  • Owner set to dkocher
  • Summary changed from Can't download S3 bucket to Access denied failure downloading S3 bucket

Can you reproduce this issue with the latest snapshot build available?

comment:2 Changed on May 10, 2015 at 11:58:41 AM by robmclear

I don't have that setting in my version of the software. Maybe because it was purchased through the Mac App Store?

comment:3 follow-up: Changed on May 12, 2015 at 6:47:40 PM by robmclear

Hi,

Would it be possible to get a copy of the non-App Store version of the software so that I can test using the latest snapshot build as you suggested above?

Thanks,

-Rob McLear

comment:4 in reply to: ↑ 3 Changed on May 13, 2015 at 7:18:17 AM by dkocher

Replying to robmclear:

Hi,

Would it be possible to get a copy of the non-App Store version of the software so that I can test using the latest snapshot build as you suggested above?

Thanks,

-Rob McLear

Yes. Please download from https://cyberduck.io/ and update to the snapshot build from within the application. Request a donation key from [feedback@…] to register this copy.

comment:6 Changed on May 13, 2015 at 11:27:58 AM by dkocher

  • Summary changed from Access denied failure downloading S3 bucket to Access denied failure downloading folder

comment:7 follow-up: Changed on May 13, 2015 at 1:34:09 PM by robmclear

Yes, the error is still present when using the latest snapshot build of the software.

Thank you.

comment:8 in reply to: ↑ 7 Changed on May 15, 2015 at 10:39:22 AM by dkocher

Replying to robmclear:

Yes, the error is still present when using the latest snapshot build of the software.

Thank you.

We can rule out an issue due to running in sandboxed environment it looks as you can reproduce with the snapshot build that does not run in a sandbox. Can you let e know if you can create a folder at ~/Desktop/Aquavet Bulk Download/10/13 or if it already exists in the Finder.

comment:9 follow-up: Changed on May 15, 2015 at 5:49:37 PM by robmclear

No, it appears that a 'file' named 10 is being created on my local file system when I attempt to download. Then the attempt to create a 'folder' named 10 fails because the file with the same name exists. But I don't know enough about how S3 stores objects to understand why it is listing both a file and a folder with the same name in the bucket I'm downloading.

Thanks.

comment:10 in reply to: ↑ 9 Changed on May 19, 2015 at 12:47:18 PM by dkocher

  • Status changed from new to assigned

Replying to robmclear:

No, it appears that a 'file' named 10 is being created on my local file system when I attempt to download. Then the attempt to create a 'folder' named 10 fails because the file with the same name exists. But I don't know enough about how S3 stores objects to understand why it is listing both a file and a folder with the same name in the bucket I'm downloading.

Thanks.

comment:11 Changed on May 19, 2015 at 1:33:26 PM by dkocher

Test in r17545.

comment:12 Changed on May 19, 2015 at 1:34:02 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r17540.

comment:13 Changed on May 19, 2015 at 2:02:48 PM by robmclear

The latest snapshot build I have access to is 17530. I will try to test it again once the snapshot has been updated. Thanks!

comment:14 Changed on May 20, 2015 at 12:57:08 PM by robmclear

It works!!! The only remaining issue I found was that it will put up warning stating:

Access denied

(Pathname).... (is a directory). Please verify disk permissions.

But if I click 'always' and Continue then the download proceeds normally.

-Rob

Note: See TracTickets for help on using tickets.
swiss made software