Cyberduck Mountain Duck CLI

#8821 closed enhancement (fixed)

Support PASSWD_CHANGEREQ requests

Reported by: ronsmithip Owned by: dkocher
Priority: low Milestone: 4.9.1
Component: sftp Version: 4.6.5
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by ronsmithip)

For one SFTP site that I use regularly, Cyberduck says the password is expired and requires me to change it. It will not proceed with the connection. SFTP from the command line works fine and doesn't not mention anything about the password being expired. FileZilla connects without complaint as well. For this site, I only have SFTP access. SSH gives me a "permission denied" error. Not sure if this is why Cyberduck doesn't work with this site.

There is only one line of text in the Log Drawer:

GlobalSCAPE Secure FTP Server

Attachments (1)

Screen Shot 2015-05-13 at 9.04.58 AM.png (98.8 KB) - added by ronsmithip on May 13, 2015 at 2:06:00 PM.
Screenshot

Download all attachments as: .zip

Change History (11)

comment:1 Changed on May 12, 2015 at 2:41:16 PM by ronsmithip

  • Description modified (diff)

comment:2 Changed on May 13, 2015 at 7:22:09 AM by dkocher

Please attach a screenshot that shows the error message displayed.

comment:3 Changed on May 13, 2015 at 7:22:27 AM by dkocher

  • Summary changed from Cyberduck says password expired and requires me to change to Password expired and requires me to change error message

comment:4 Changed on May 13, 2015 at 7:24:31 AM by dkocher

  • Milestone set to 4.8
  • Status changed from new to assigned
  • Summary changed from Password expired and requires me to change error message to Support PASSWD_CHANGEREQ requests
  • Type changed from defect to enhancement

Changed on May 13, 2015 at 2:06:00 PM by ronsmithip

Screenshot

comment:5 Changed on May 13, 2015 at 2:12:25 PM by ronsmithip

For the record, there is no error message. Cyberduck just refuses to connect while sftp on the command line and FileZilla do not mention anything about an expired password nor do they require a password change -- they allow me to connect, up/download files, etc. as usual. Cyberduck says the password is expired, prompts me to change the password, and will not connect without changing the password. I have tried changing the password using the cyberduck prompts and that does not work (I don't think the server will allow me to change the password for this login).

comment:7 Changed on Jul 1, 2015 at 12:07:41 PM by dkocher

  • Priority changed from normal to low
  • Severity changed from major to normal

comment:8 Changed on Nov 6, 2015 at 8:31:10 AM by dkocher

#9099 closed as duplicate.

comment:9 Changed on Nov 6, 2015 at 1:17:40 PM by ronsmithip

Never mind, I just figured out that you closed some other ticket as a duplicate of this one.

Duplicate of??? I'd like to follow the ticket you are going to fix.

Last edited on Nov 6, 2015 at 1:23:41 PM by ronsmithip (previous) (diff)

comment:10 Changed on Apr 9, 2016 at 11:53:30 AM by dkocher

  • Milestone changed from 5.0 to 4.9.1
  • Resolution set to fixed
  • Status changed from assigned to closed

In r20074.

Note: See TracTickets for help on using tickets.
swiss made software