Cyberduck Mountain Duck CLI

#8874 closed defect (fixed)

Missing Sparkle framework dependency

Reported by: tobias.boyd Owned by: dkocher
Priority: normal Milestone: 4.7.1
Component: core Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.9

Description (last modified by dkocher)

From my console:

6/12/15 10:51:32.761 AM Cyberduck[40009]: [main] ERROR org.rococoa.callback - Exception calling method for selector updateMenuClicked:

java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at org.rococoa.internal.OCInvocationCallbacks.callMethod(OCInvocationCallbacks.java:170)
    at org.rococoa.internal.OCInvocationCallbacks.access$200(OCInvocationCallbacks.java:52)
    at org.rococoa.internal.OCInvocationCallbacks$2.callback(OCInvocationCallbacks.java:82)
    at sun.reflect.GeneratedMethodAccessor13.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:497)
    at com.sun.jna.CallbackReference$DefaultCallbackProxy.invokeCallback(CallbackReference.java:470)
    at com.sun.jna.CallbackReference$DefaultCallbackProxy.callback(CallbackReference.java:500)
    at com.sun.jna.Native.invokeVoid(Native Method)
    at com.sun.jna.Function.invoke(Function.java:367)
    at com.sun.jna.Function.invoke(Function.java:315)
    at org.rococoa.internal.MsgSendHandler.invoke(MsgSendHandler.java:111)
    at com.sun.jna.Library$Handler.invoke(Library.java:210)
    at com.sun.proxy.$Proxy0.syntheticSendMessage(Unknown Source)
    at org.rococoa.Foundation.send(Foundation.java:208)
    at org.rococoa.Foundation.send(Foundation.java:194)
    at org.rococoa.internal.ObjCObjectInvocationHandler.sendOnThisOrMainThread(ObjCObjectInvocationHandler.java:269)
    at org.rococoa.internal.ObjCObjectInvocationHandler.invokeCocoa(ObjCObjectInvocationHandler.java:232)
    at org.rococoa.internal.ObjCObjectInvocationHandler.intercept(ObjCObjectInvocationHandler.java:191)
    at ch.cyberduck.binding.application.NSApplication$$ByRococoa.run(<generated>)
    at ch.cyberduck.ui.cocoa.MainApplication.main(MainApplication.java:80)
Caused by: java.lang.NullPointerException
    at ch.cyberduck.core.sparkle.Updater.create(Updater.java:35)
    at ch.cyberduck.ui.cocoa.MainController.updateMenuClicked(MainController.java:199)
    ... 25 more


Change History (3)

comment:1 Changed on Jun 13, 2015 at 8:32:33 PM by dkocher

  • Description modified (diff)
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Jun 13, 2015 at 8:40:39 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r17738.

comment:3 Changed on Jun 14, 2015 at 7:01:52 PM by dkocher

  • Summary changed from Java error thrown in 17726 on OSX 10.9.5 selecting Check for Update... to Missing Sparkle framework dependency
Note: See TracTickets for help on using tickets.
swiss made software