Cyberduck Mountain Duck CLI

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8885 closed defect (fixed)

Certificate chain displayed not complete

Reported by: wwwpixime Owned by: dkocher
Priority: normal Milestone: 4.7.3
Component: core Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.10

Description

on OSX 10.10.3 and CyberDuck 4.8 (build 17762), clicking on the padlock button brings up a dialog box where the Certificate Heiarchy is not complete - it gets cut off at the Intermediate CA level - the actual target Server certificate details are not displayed at all.

Change History (7)

comment:1 Changed 3 years ago by dkocher

  • Milestone set to 4.8
  • Platform set to Mac OS X 10.10
  • Summary changed from Certificate Heiarchy on OSX 10.10.3 is not complete to Certificate chain displayed not complete

comment:2 Changed 3 years ago by wwwpixime

test server to reproduce the error:

https://dav.pixi.me/

(Platform) FreeBSD, Apache 2.4, mod_dav, OpenSSL 1.0.2c

comment:3 Changed 3 years ago by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned

comment:4 Changed 3 years ago by dkocher

We had this previously reported in #8698.

comment:5 Changed 3 years ago by dkocher

This is possibly caused by change r17291. See also #8741.

comment:6 Changed 3 years ago by dkocher

Added tests in r17850.

comment:7 Changed 3 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r18030.

Last edited 3 years ago by dkocher (previous) (diff)
Note: See TracTickets for help on using tickets.
swiss made software