Cyberduck Mountain Duck CLI

#8887 closed defect (fixed)

Listing directory [deleted folder] failed.

Reported by: wwwpixime Owned by: dkocher
Priority: normal Milestone: 4.7.1
Component: core Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

on OSX 10.10.3 and CyberDuck 4.8 (build 17762), when a folder is deleted containing 1 or more files, a "Listing directory [deleted folder name] failed" dialog box is presented.

from the log files, it looks like CyberDuck issues several DELETE requests (to delete existing files), followed by a "DELETE /path/to/folder/" request followed by "PROPFIND /path/to/folder/" where a 404 server status is thrown, then a "PROPFIND /" after you hit "Ok".

the problem doesn't exist if the target folder (and/or sub-folders) are already empty.

Change History (3)

comment:1 Changed on Jun 18, 2015 at 11:24:28 AM by wwwpixime

test server to reproduce the error:

https://dav.pixi.me/

(Platform) FreeBSD, Apache 2.4, mod_dav, OpenSSL 1.0.2c

comment:2 Changed on Jun 18, 2015 at 11:48:10 AM by dkocher

  • Milestone set to 4.8
  • Owner set to dkocher
  • Status changed from new to assigned

comment:3 Changed on Jun 18, 2015 at 11:56:12 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r17783.

Note: See TracTickets for help on using tickets.
swiss made software