Cyberduck Mountain Duck CLI

#8897 closed defect (worksforme)

Failure connecting with no login prompt

Reported by: frankbwalsh Owned by: dkocher
Priority: highest Milestone: 4.7.1
Component: google-storage Version: 4.7
Severity: major Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by frankbwalsh)

Still happening.

Attachments (1)

cyberduck.log (710.1 KB) - added by frankbwalsh on Jun 25, 2015 at 8:04:36 PM.
Cyberduck Log File - Removed my Google UserID with String Replace..

Download all attachments as: .zip

Change History (14)

comment:1 Changed on Jun 25, 2015 at 9:13:36 AM by dkocher

Please attach the file cyberduck.log in the application support directory.

comment:2 Changed on Jun 25, 2015 at 9:13:58 AM by dkocher

  • Summary changed from GCS links no longer work in CyberDuck 4.7. to Failure connecting

Changed on Jun 25, 2015 at 8:04:36 PM by frankbwalsh

Cyberduck Log File - Removed my Google UserID with String Replace..

comment:3 Changed on Jun 25, 2015 at 8:04:53 PM by frankbwalsh

Attached..

comment:4 Changed on Jun 26, 2015 at 8:54:45 AM by dkocher

2015-06-25 15:58:00,926 [Thread-0] DEBUG ch.cyberduck.core.SessionFactory - Create session for Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,929 [Thread-0] ERROR ch.cyberduck.core.ssl.CustomTrustSSLProtocolSocketFactory - Failure NativePRNG SecureRandom not available obtaining secure random NativePRNG
2015-06-25 15:58:00,930 [Thread-0] DEBUG ch.cyberduck.core.ssl.CustomTrustSSLProtocolSocketFactory - Using SSL context with protocol TLS
2015-06-25 15:58:00,930 [Thread-0] DEBUG ch.cyberduck.core.http.HttpSession - Setup connection pool with registry {http=ch.cyberduck.core.http.HttpSession$1@3fb5885, https=ch.cyberduck.core.http.HttpSession$2@3d61cae}
2015-06-25 15:58:00,937 [Thread-0] DEBUG ch.cyberduck.core.AbstractController - Run action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null} in background
2015-06-25 15:58:00,939 [Thread-0] DEBUG ch.cyberduck.core.AbstractController - Synchronize on lock Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed} for action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null}
2015-06-25 15:58:00,939 [Thread-0] INFO  ch.cyberduck.core.AbstractController - Scheduled background runnable WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null} for execution
2015-06-25 15:58:00,939 [background-1] DEBUG ch.cyberduck.core.AbstractController - Releasing lock for background runnable WorkerBackgroundAction{worker=DisconnectWorker{session=Session{host=Host{credentials=Credentials{user='AKIAIDERNO27D2GV74AQ'}, hostname='s3.amazonaws.com', port=443, protocol=s3}, state=closed}}, result=null}
2015-06-25 15:58:00,940 [background-1] DEBUG ch.cyberduck.core.AbstractController - Acquired lock for background runnable WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null}
2015-06-25 15:58:00,940 [background-1] DEBUG ch.cyberduck.core.AbstractController - Prepare background action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null}
2015-06-25 15:58:00,940 [background-1] DEBUG ch.cyberduck.core.threading.AbstractBackgroundAction - Prepare background task WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null}
2015-06-25 15:58:00,943 [background-1] DEBUG ch.cyberduck.core.AbstractController - Call background action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=closed}}, result=null}
2015-06-25 15:58:00,943 [background-1] DEBUG ch.cyberduck.core.KeychainLoginService - Validate login credentials for Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,943 [background-1] INFO  ch.cyberduck.core.HostPasswordStore - Fetching password from keychain for Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,943 [background-1] WARN  ch.cyberduck.core.preferences.Preferences - No property with key 'https://<REMOVED FROM LOG BY FRANK>@storage.googleapis.com'
2015-06-25 15:58:00,943 [background-1] INFO  ch.cyberduck.core.HostPasswordStore - Password not found in keychain for Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,944 [background-1] DEBUG ch.cyberduck.core.threading.NamedThreadFactory - Create thread for runnable ch.cyberduck.core.Resolver$1@198a4b6
2015-06-25 15:58:00,944 [background-1] DEBUG ch.cyberduck.core.Resolver - Waiting for resolving of storage.googleapis.com
2015-06-25 15:58:00,972 [resolver-1] INFO  ch.cyberduck.core.Resolver - Resolved storage.googleapis.com to 173.194.207.128
2015-06-25 15:58:00,972 [background-1] DEBUG ch.cyberduck.core.Session - Connection will open to Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,972 [background-1] DEBUG ch.cyberduck.core.s3.S3Session - Configure for endpoint Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,972 [background-1] DEBUG org.jets3t.service.Jets3tProperties - s3service.https-only=true
2015-06-25 15:58:00,972 [background-1] DEBUG org.jets3t.service.Jets3tProperties - storage-service.internal-error-retry-max=0
2015-06-25 15:58:00,972 [background-1] DEBUG org.jets3t.service.Jets3tProperties - storage-service.apply-recommended-dns-caching-defaults=true
2015-06-25 15:58:00,972 [background-1] DEBUG org.jets3t.service.StorageService - Setting recommended DNS caching defaults
2015-06-25 15:58:00,973 [background-1] DEBUG org.jets3t.service.StorageService - Using DNS caching system settings: networkaddress.cache.ttl=300, networkaddress.cache.negative.ttl=1
2015-06-25 15:58:00,973 [background-1] DEBUG org.jets3t.service.Jets3tProperties - s3service.default-storage-class=null
2015-06-25 15:58:00,973 [background-1] DEBUG org.jets3t.service.Jets3tProperties - s3service.server-side-encryption=null
2015-06-25 15:58:00,973 [background-1] DEBUG org.jets3t.service.Jets3tProperties - devpay.user-token=null
2015-06-25 15:58:00,973 [background-1] DEBUG org.jets3t.service.Jets3tProperties - devpay.product-token=null
2015-06-25 15:58:00,973 [background-1] DEBUG org.jets3t.service.Jets3tProperties - httpclient.requester-pays-buckets-enabled=false
2015-06-25 15:58:00,973 [background-1] DEBUG ch.cyberduck.core.Session - Connection did open to Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:00,974 [background-1] DEBUG ch.cyberduck.core.KeychainLoginService - Attempt authentication for Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}
2015-06-25 15:58:05,690 [background-1] DEBUG ch.cyberduck.core.threading.AbstractBackgroundAction - Finish background task WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=open}}, result=null}
2015-06-25 15:58:05,690 [background-1] DEBUG ch.cyberduck.core.threading.BackgroundActionRegistry - Remove action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=open}}, result=null}
2015-06-25 15:58:05,690 [background-1] DEBUG ch.cyberduck.core.AbstractController - Invoke cleanup for background action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=open}}, result=null}
2015-06-25 15:58:05,691 [Thread-0] DEBUG ch.cyberduck.core.threading.BackgroundActionRegistry - Remove action WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=open}}, result=null}
2015-06-25 15:58:05,691 [Thread-0] WARN  ch.cyberduck.core.threading.WorkerBackgroundAction - Missing result for worker MountWorker{session=Session{host=Host{credentials=Credentials{user='<REMOVED FROM LOG BY FRANK>'}, hostname='storage.googleapis.com', port=443, protocol=gs}, state=open}}. Use default value.

comment:5 Changed on Jun 26, 2015 at 8:55:02 AM by dkocher

  • Summary changed from Failure connecting to Failure connecting with no login prompt

comment:6 Changed on Jun 26, 2015 at 8:56:30 AM by dkocher

Can you confirm that you don't get a OAuth2 Authentication prompt at all.

comment:7 Changed on Jun 26, 2015 at 11:55:34 AM by dkocher

  • Milestone set to 4.7.1
  • Status changed from new to assigned

The issues affects all TLS connections.

2015-06-26 13:52:00,674 [background-1] DEBUG ch.cyberduck.core.http.HttpConnectionPoolBuilder$2 - Connecting socket to svn.cyberduck.io/54.228.253.92:443 with timeout 30000
2015-06-26 13:52:00,722 [background-1] INFO  ch.cyberduck.core.ssl.CertificateStoreX509KeyManager - Load default store of type Windows-MY
2015-06-26 13:52:00,722 [background-1] DEBUG ch.cyberduck.core.threading.AbstractBackgroundAction - Finish background task WorkerBackgroundAction{worker=MountWorker{session=Session{host=Host{credentials=Credentials{user='anonymous'}, hostname='svn.cyberduck.io', port=443, protocol=davs}, state=open}}, result=null}

comment:8 Changed on Jun 26, 2015 at 1:54:49 PM by dkocher

This is a possible duplicate of #8162. Can you please try to install Microsoft Visual C++ 2010 Redistributable Package (x86).

comment:9 Changed on Jun 29, 2015 at 9:07:45 AM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Please update to the latest snapshot build available.

comment:10 Changed on Jul 1, 2015 at 2:42:10 PM by frankbwalsh

I actually re-installed the redistributable package and I installed the latest snapshot build. Neither resolved this issue.

comment:11 follow-up: Changed on Jul 1, 2015 at 2:43:14 PM by frankbwalsh

  • Description modified (diff)
  • Resolution duplicate deleted
  • Status changed from closed to reopened

I actually re-installed the redistributable package and I installed the latest snapshot build. Neither resolved this issue.

comment:12 in reply to: ↑ 11 Changed on Jul 2, 2015 at 7:39:15 AM by dkocher

Replying to frankbwalsh:

I actually re-installed the redistributable package and I installed the latest snapshot build. Neither resolved this issue.

Can you again attach the current cyberduck.log file.

comment:13 Changed on Jul 9, 2015 at 8:47:09 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software