Cyberduck Mountain Duck CLI

#8911 closed defect (fixed)

Uploading multiple files fails after the first file

Reported by: beppodb Owned by:
Priority: normal Milestone: 4.7.3
Component: irods Version: 4.7.1
Severity: normal Keywords: irods upload multiple files
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

When I attempt to upload multiple files at once to an iRODS repository, the first file is uploaded successfully, but the transfer stops, showing "Transfer Incomplete".

This issue does not occur when uploading to the same repository via WebDAV.

I have tried to gather logs, but logging via the Log Drawer does not appear to work when connecting to an iRODS repository.

Change History (7)

comment:1 follow-up: Changed on Jul 7, 2015 at 9:26:55 AM by dkocher

  • Milestone set to 4.8
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue with 4.7.1. I have tested both multiple files and a directory containing multiple files.

comment:2 in reply to: ↑ 1 Changed on Jul 15, 2015 at 10:48:27 AM by cjs-uu

Replying to dkocher:

I cannot reproduce this issue with 4.7.1. I have tested both multiple files and a directory containing multiple files.

I'm experiencing the same issue when connecting to an iRODS 3.3.1 server using Cyberduck 4.7.1 on Windows 7.

The problem occurs when I drag and drop either a directory or multiple files into Cyberduck. The transfer dialog shows Transfer incomplete and after refreshing the target directory only the first file is present. Pressing the Resume button seems to have no effect.

I've also tried the 3 available transfer options (open new connection, multiple connections, use browser connection), to no avail.

Uploading files in the same manner using Cyberduck's WebDAV connection to irods-webdav (which uses Jargon as well) does work.

comment:3 Changed on Jul 16, 2015 at 11:15:02 AM by dkocher

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:4 Changed on Jul 16, 2015 at 1:08:44 PM by dkocher

  • Summary changed from Uploading multiple files to iRODS fails after the first file to Uploading multiple files fails after the first file

comment:5 Changed on Aug 4, 2015 at 7:42:13 PM by dkocher

#8967 closed as duplicate.

comment:6 Changed on Sep 4, 2015 at 1:37:15 PM by dkocher

Referencing #143 and #141.

comment:7 Changed on Oct 21, 2015 at 12:19:41 PM by dkocher

  • Milestone changed from 4.8 to 4.7.3
  • Resolution set to fixed
  • Status changed from reopened to closed

In r18387.

Note: See TracTickets for help on using tickets.
swiss made software