Cyberduck Mountain Duck CLI

#8912 closed defect (worksforme)

Excess memory usage (1gb+ )

Reported by: YesThatAllen Owned by:
Priority: normal Milestone: 4.7.3
Component: core Version: Nightly Build
Severity: major Keywords:
Cc: Architecture:
Platform: Mac OS X 10.10

Description (last modified by dkocher)

on my 10.10.4 box, Cyberduck 4.8 is consuming 1.2+ gb of memory on launch

 Cyberduck	1.21 GB	258.6 MB	50	383	33946	ahancock	0.1	1:32.95			-	No	No	No	0 bytes	0 bytes	0	0	0 bytes	0 bytes	64 bit	0 bytes	0 bytes	0 bytes	No	No		0 bytes	

What kind of report should I run to help provide more insight?

Change History (4)

comment:1 Changed on Jul 7, 2015 at 8:49:12 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Jul 10, 2015 at 6:06:03 AM by YesThatAllen

Downgrading to 4.7.1 (release, non mac app store) shows 539MB on launch / idle.

comment:3 Changed on Aug 24, 2015 at 8:12:09 AM by dkocher

  • Milestone set to 4.8

comment:4 Changed on Aug 24, 2015 at 8:20:16 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Latest snapshot build r18026 requires ~200MB after launch. I cannot reproduce the issue. This is still more than desired but unfortunately a given constraint due to the architecture of Cyberduck with an embedded runtime.

Note: See TracTickets for help on using tickets.