Cyberduck Mountain Duck CLI

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#8928 closed defect (fixed)

NSInternalInconsistencyException in NSSavePanel

Reported by: seoras Owned by: dkocher
Priority: high Milestone: 4.7.2
Component: sftp Version: 4.7.1
Severity: critical Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by dkocher)

App Store automatically updated to Version 4.7.1 (17885) and now I can't connect to either of my bookmarked servers. Using SFTP in both cases with public key authentication to Amazon AWS instances running latest ubuntu

Application Specific Information:
*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: 'not running on AppKit (main) thread'
terminating with uncaught exception of type NSException
abort() called

Attachments (1)

cyberduck crash log.txt (101.5 KB) - added by seoras 3 years ago.
Crash log output

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by seoras

Crash log output

comment:1 Changed 3 years ago by dkocher

  • Component changed from core to sftp
  • Milestone set to 4.8
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Crash on connection attempt "exception 'NSInternalInconsistencyException', reason: 'not running on AppKit (main) thread'" to NSInternalInconsistencyException in NSSavePanel

This affects login prompts with public key authentication.

comment:2 Changed 3 years ago by dkocher

  • Description modified (diff)

comment:3 Changed 3 years ago by dkocher

Regression from r17532.

comment:4 Changed 3 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r17969.

comment:5 Changed 3 years ago by dkocher

Please update to the latest snapshot build available.

comment:6 Changed 3 years ago by dkocher

  • Milestone changed from 4.8 to 4.7.2
Note: See TracTickets for help on using tickets.
swiss made software