Cyberduck Mountain Duck CLI

#8943 closed defect (thirdparty)

Bad Padding and InputRecord

Reported by: kindnessclothing Owned by: dkocher
Priority: high Milestone:
Component: webdav Version: 4.4.3
Severity: normal Keywords: invalid padding
Cc: Architecture:
Platform: Windows Vista

Description

I am a user via Big Commerce. Unbeknownst to me, the only version that works well with Big Commerce is 4.4.3. 2 days ago when prompted to download the newest version of Cyberduck, I did so since I didn't know any better. It logged me in successfully via Big Commerce but when I tried to access the "product_images" and then "uploaded images" folder, it gave me error messages. I have now been on the phone with Big Commerce's helpline for multiple hours and they're still not able to replicate the error on their end. Currently, they have their engineers looking into it to see if they can come up with a solution but I figured I might come straight to the source and see what you all can do as well. Here are the things we have tried: uninstalling the latest version, re-installing the 4.4.3 version (they flushed the cache, I have logged out and logged back in to B.C multiple times), I have re-started my computer. No matter what, cyberduck has no problem recognizing me and making the connection to my Big Commerce store, but when I try to access that ONE file, it won't let me. I know the images are still there because they're showing up for the folks at Big Commerce. Here is the text from 1 error message: Bad InputRecord, count= 54093, buf.length = 16921. Another error message had a more detailed thing saying "invalid padding". Can someone please help me troubleshoot? Thank you!

Attachments (2)

1.jpg (47.9 KB) - added by kindnessclothing on Jul 22, 2015 at 2:31:34 PM.
Error 1
2.jpg (52.4 KB) - added by kindnessclothing on Jul 22, 2015 at 2:31:52 PM.
Error 2

Download all attachments as: .zip

Change History (4)

Changed on Jul 22, 2015 at 2:31:34 PM by kindnessclothing

Error 1

Changed on Jul 22, 2015 at 2:31:52 PM by kindnessclothing

Error 2

comment:1 Changed on Jul 22, 2015 at 3:10:09 PM by dkocher

The server is sending an invalid SSL/TLS record. Please let us know if you can reproduce the issue with version 4.7.

comment:2 Changed on Jul 22, 2015 at 3:36:34 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.