Cyberduck Mountain Duck CLI

Opened 12 years ago

Closed 11 years ago

#896 closed defect (fixed)

Hitting letter key in file listing jumps to wrong filename

Reported by: anonymous Owned by: dkocher
Priority: normal Milestone: 2.8
Component: interface Version: 2.6.2
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Reproduce: 1) Open a connection listing several files 2) Hit a letter key which corresponds to the first letter of one of the files 3) Observe that the newly highlighted file name does not begin with the letter (how was it chosen?) [Sometimes it works, but mostly it doesn't.]

Expected Behavior: Like Finder, the file listing should highlight the first filename which begins with the pressed letter.

Change History (2)

comment:1 Changed 11 years ago by jazbek

This is almost fixed in 2.7.2. If you type a letter, it will jump to the first file that begins with that letter. However, if you type another letter after that, even if it's been over a minute since you typed the last letter, it will always go to the next file in the list that begins with the same letter as the *first* one you typed, unless there are no other files that begin with that letter, in which case it does nothing. If you type a third letter, it will then correctly jump to the letter you type.

To reproduce:

1) Open a connection to an FTP directory that has a bunch of files
2) Click on a file in the list (so that the directory list has focus)
3) Type a letter. The highlighted file will be the first file that starts with that letter.
4) Wait a minute (switch to other apps, etc.), and type another letter. The highlighted element will be the next one that starts with the letter typed in step 3 if there are any other files that begin with that letter. If there aren't, nothing will happen.
5) Type another letter. Normal behavior resumes and the highlighted element will be the first one that starts with the letter you type.

Expected behavior: After you type 1 letter, the app should wait a few seconds to see if you type another letter, because you might be typing the beginning of a filename to jump to that specific file. After a few seconds, if there is no input, reset the letters typed so that the next letter you type is considered to be the first letter again.

comment:2 Changed 11 years ago by dkocher

  • Milestone set to 2.8
  • Resolution set to fixed
  • Status changed from new to closed
  • Summary changed from hitting letter key in file listing jumps to wrong filename to Hitting letter key in file listing jumps to wrong filename

Fixed in r2995.

Note: See TracTickets for help on using tickets.
swiss made software