Cyberduck Mountain Duck CLI

#9018 closed enhancement (fixed)

Unselecting "Use system proxy settings" in Preferences provides no user interface for application-specific proxy settings

Reported by: ducklips Owned by:
Priority: normal Milestone: 4.7.3
Component: core Version: 4.7.2
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.10

Description

If you select "Use system proxy settings" in Cyberduck preferences, and then click the "Change settings..." button, System Preferences is opened to the Network preferences panel, to the Proxies tab in the Advanced settings for the default adapter. This behavior makes sense.

But if you unselect "Use system proxy settings" in Cyberduck preferences, and then click the "Change settings..." button, the button event handler does the same thing. I would have expected a Cyberduck provided UI for making Cyberduck-specific proxy settings, or perhaps unselecting the checkbox would replace the button with a bunch of text fields similar to what the System Prefs' NPP Proxies tab presents.

(This seems to be a defect insofar as the expected behavior seems absent. But I suppose this could be an enhancement.)

Change History (6)

comment:1 Changed on Sep 17, 2015 at 7:22:55 PM by dkocher

  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Unselecting "Use system proxy settings" in Cyberduck preferences provides no UI for Cyberduck-specific proxy settings to Unselecting "Use system proxy settings" in Preferences provides no user interface for application-specific proxy settings
  • Type changed from defect to enhancement

Duplicate for #5815. We are very reluctant to duplicate functionality already provided by the system thus duplicating efforts and bugs. Also, proxy settings should affect all installed applications and not to be configured separately in every application.

comment:2 follow-up: Changed on Sep 17, 2015 at 8:14:52 PM by ducklips

I think the UI needs to be redesigned in that area of the Preferences window, because it is misleading. Disable the button if the checkbox is unchecked. Or at least provide a label or tool tip to explain the semantics of the controls, which are not consistent with the way that most browsers work.

comment:3 in reply to: ↑ 2 Changed on Sep 17, 2015 at 8:18:49 PM by dkocher

  • Milestone set to 4.8
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to ducklips:

I think the UI needs to be redesigned in that area of the Preferences window, because it is misleading. Disable the button if the checkbox is unchecked.

Disabling the button would certainly make sense.

comment:4 follow-up: Changed on Sep 18, 2015 at 3:59:28 PM by ducklips

Thinking about this a bit more this morning, the user expectation problem stems from the ambiguity of what the unchecked state actually maps to. This could be resolved by replacing the checkbox with a radio button group (which is much more congruent with the way these options are presented in Seamonkey / Firefox / etc.) so that the states are clear. I would think the labels would be:

  • Use system proxy settings (and put the button next to or under this radio button label, and disable it if this radio button wasn't selected)
  • Direct Connection

Just a thought...

comment:5 in reply to: ↑ 4 Changed on Sep 19, 2015 at 6:15:18 PM by dkocher

Replying to ducklips:

Thinking about this a bit more this morning, the user expectation problem stems from the ambiguity of what the unchecked state actually maps to. This could be resolved by replacing the checkbox with a radio button group (which is much more congruent with the way these options are presented in Seamonkey / Firefox / etc.) so that the states are clear. I would think the labels would be:

  • Use system proxy settings (and put the button next to or under this radio button label, and disable it if this radio button wasn't selected)
  • Direct Connection

Just a thought...

We use the same semantics as in Safari to change proxy settings in the network pane of System Preferences with the only difference that you can uncheck the option to ignore these settings and use a direct connection instead. A radio button would only make sense if the options are not boolean but more numerous.

comment:6 Changed on Sep 20, 2015 at 4:39:23 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r18184.

Note: See TracTickets for help on using tickets.
swiss made software