Cyberduck Mountain Duck CLI

#9024 closed defect (fixed)

New profiles fail to populate the bookmark panel correctly

Reported by: owithoff Owned by: dkocher
Priority: normal Milestone: 4.7.3
Component: core Version: 4.7.2
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by dkocher)

I'm using CyberDuck with SoftLayer's Object Storage (and implementation of SWIFT). I had one CyberDuck profile created by SoftLayer for their dal05 SWIFT region, and that works fine (very simple XML doc anyways).

When I use that as a reference to create new profiles for other regions, some of the fields fail to populate correctly in the bookmarker/connection UI, and seem to hold on to some of the values.

I've tried rebooting my Windows machine between changes.

See attached screen grab of the dialog.

Dallas profile: =========

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
    <dict>
        <key>Protocol</key>
        <string>swift</string>
        <key>Vendor</key>
        <string>softlayer-dal05-networklayer</string>
        <key>Description</key>
        <string>Softlayer Object Storage (Dallas)</string>
        <key>Default Hostname</key>
        <string>dal05.objectstorage.service.networklayer.com</string>
        <key>Default Port</key>
        <string>443</string>
        <key>Hostname Configurable</key>
        <false/>
        <key>Port Configurable</key>
        <false/>
        <key>Context</key>
        <string>/auth/v1.0</string>
        <key>Username Placeholder</key>
        <string>Username</string>
        <key>Password Placeholder</key>
        <string>API Key</string>
    </dict>
</plist>

Toronto Profile: ==========

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
    <dict>
        <key>Protocol</key>
        <string>swift</string>
        <key>Vendor</key>
        <string>softlayer-tor01-networklayer</string>
        <key>Description</key>
        <string>Softlayer Object Storage (Toronto)</string>
        <key>Default Hostname</key>
        <string>tor01.objectstorage.service.networklayer.com</string>
        <key>Default Port</key>
        <string>443</string>
        <key>Hostname Configurable</key>
        <false/>
        <key>Port Configurable</key>
        <false/>
        <key>Context</key>
        <string>/auth/v1.0</string>
        <key>Username Placeholder</key>
        <string>Username</string>
        <key>Password Placeholder</key>
        <string>API Key</string>
    </dict>
</plist>

Attachments (3)

dialog1.jpg (61.5 KB) - added by owithoff on Sep 22, 2015 at 3:38:51 PM.
Showing Toronto profile, but with Dallas fields
softlayer-dal05-networklayer.cyberduckprofile (914 bytes) - added by dkocher on Sep 23, 2015 at 8:34:49 AM.
softlayer-tor01-networklayer.cyberduckprofile (914 bytes) - added by dkocher on Sep 23, 2015 at 8:34:56 AM.

Download all attachments as: .zip

Change History (8)

Changed on Sep 22, 2015 at 3:38:51 PM by owithoff

Showing Toronto profile, but with Dallas fields

comment:1 Changed on Sep 22, 2015 at 3:41:06 PM by dkocher

  • Description modified (diff)
  • Milestone set to 4.8

comment:2 Changed on Sep 23, 2015 at 8:35:31 AM by dkocher

Cannot reproduce this on OS X. Will need to see if there is a specific bug in the Windows version handling profiles in the bookmark panel.

Last edited on Oct 16, 2015 at 8:10:44 AM by dkocher (previous) (diff)

comment:3 Changed on Sep 23, 2015 at 8:37:06 AM by dkocher

  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from New profiles fail to populate the Windows UI correctly. to New profiles fail to populate the bookmark panel correctly

comment:4 Changed on Oct 16, 2015 at 8:10:29 AM by dkocher

As a workaround repeat selecting the other profile from the dropdown menu.

comment:5 Changed on Oct 16, 2015 at 8:44:11 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r18364.

Note: See TracTickets for help on using tickets.