Cyberduck Mountain Duck CLI

#9042 closed defect (duplicate)

Synchronize empties all local and server files

Reported by: ebaker7 Owned by: dkocher
Priority: high Milestone: 4.7.3
Component: core Version: 4.7.2
Severity: major Keywords: synchronize
Cc: Architecture:
Platform: Mac OS X 10.10

Description

I tried to use Synchronize to download all files in a certain server folder to a folder on my local computer. I set it to Download. It seemed to run the synchronization, but unexpectedly quickly. After it was done, all the files in the structure were on the local computer, but every file was 0bytes. When I looked at the server, the files there had been emptied as well! A huge amount of important files were emptied of all of their information for no apparent reason. This is a terrible bug, and I'm not sure why anyone would be using an application that could make such an error.

Change History (6)

comment:1 Changed on Oct 8, 2015 at 9:52:14 AM by dkocher

  • Milestone set to 4.8
  • Owner set to dkocher
  • Severity changed from normal to major
  • Status changed from new to assigned

comment:2 Changed on Oct 9, 2015 at 9:22:25 PM by PaulJBis

I can confirm this bug exists too. Details:

-I am using OS X 10.9.5. Cyberduck version 4.7.2. -I connect to a WebDAV server, choose the "Syncronize" option and choose "Download". -What happens is: every file downloaded has 0 bytes, but also has with it a resource fork that takes 200Kb. I'm not sure about what's in the resource fork; it seems to be binary data (the icon, perhaps?) Also, every file downloaded has the Cyberduck icon, instead of the one corresponding to its type (HTML, TXT, etc.).

BTW, I have also lost data due to this: a few days ago I used Cyberduck for the first time and set it to "Mirror": I don't know how, but it overwrote all the files in the server and set them to 0 bytes. Since then, I've been making tests only with the "Download" option.

comment:3 Changed on Oct 14, 2015 at 7:32:21 AM by dkocher

  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate for #8993.

comment:4 Changed on Oct 14, 2015 at 7:34:02 AM by dkocher

  • Summary changed from Cyberduck Synchronize empties all local and server files to Synchronize empties all local and server files

Duplicate for #8657.

comment:5 Changed on Oct 14, 2015 at 7:37:07 AM by dkocher

You should find the blanked files in the Trash.

Note: See TracTickets for help on using tickets.
swiss made software