Cyberduck Mountain Duck CLI

#9177 closed defect (fixed)

Null pointer in S3AccessControlListFeature

Reported by: xiao Owned by: yla
Priority: highest Milestone: 4.8
Component: s3 Version: 4.9.1
Severity: blocker Keywords:
Cc: Architecture:
Platform:

Description (last modified by rblaa)

I'm using 4.7.3 to upload a folder to S3, Mac client works well, but on Windows there's 'Transfer incomplete' error after uploading each file. I'm using the same aws user and bucket/folder. Uploading one file has no problem on both platforms.

Attachments (1)

cyberduck.log (108.4 KB) - added by xiao on Dec 23, 2015 at 4:02:00 PM.
cyberduck.log

Download all attachments as: .zip

Change History (10)

Changed on Dec 23, 2015 at 4:02:00 PM by xiao

cyberduck.log

comment:1 Changed on Dec 23, 2015 at 9:04:06 PM by xiao

  • Component changed from core to s3
  • Owner set to dkocher

comment:2 Changed on Jan 4, 2016 at 1:37:24 PM by dkocher

  • Milestone set to 4.8
  • Status changed from new to assigned
  • Summary changed from Upload folder to S3 from Windows tool, get Transfer incomplete error after uploading each file to Null pointer in S3AccessControlListFeature

comment:3 Changed on Jan 4, 2016 at 1:38:01 PM by dkocher

Caused by: java.lang.NullPointerException
	at ch.cyberduck.core.s3.S3AccessControlListFeature.convert(S3AccessControlListFeature.java:128)
	at ch.cyberduck.core.s3.S3AccessControlListFeature.setPermission(S3AccessControlListFeature.java:112)
	at ch.cyberduck.core.transfer.upload.AbstractUploadFilter.complete(AbstractUploadFilter.java:290)
	at ch.cyberduck.core.worker.AbstractTransferWorker$3.call(AbstractTransferWorker.java:422)
	at ch.cyberduck.core.worker.SingleTransferWorker.submit(SingleTransferWorker.java:84)
	at ch.cyberduck.core.worker.AbstractTransferWorker.transfer(AbstractTransferWorker.java:374)
	at ch.cyberduck.core.worker.AbstractTransferWorker.run(AbstractTransferWorker.java:236)
	at ch.cyberduck.core.worker.AbstractTransferWorker.run(AbstractTransferWorker.java:64)
	at ch.cyberduck.core.threading.WorkerBackgroundAction.run(WorkerBackgroundAction.java:110)
	at ch.cyberduck.core.threading.TransferCollectionBackgroundAction.run(TransferCollectionBackgroundAction.java:93)
	at ch.cyberduck.core.threading.TransferCollectionBackgroundAction.run(TransferCollectionBackgroundAction.java:40)
	at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
	at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:184)
	at ch.cyberduck.core.threading.WorkerBackgroundAction.call(WorkerBackgroundAction.java:121)
	at ch.cyberduck.core.AbstractController$BackgroundCallable.call(AbstractController.java:175)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:618)
	at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
	at java.lang.Thread.run(Thread.java:955)
 

comment:4 Changed on Jan 18, 2016 at 2:13:48 PM by dkocher

  • Owner changed from dkocher to yla
  • Status changed from assigned to new

comment:5 Changed on Jan 21, 2016 at 1:39:25 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Please update to the latest snapshot build available and reopen this issue if the problem persists.

comment:6 Changed on Apr 25, 2016 at 11:50:40 PM by rblaa

  • Description modified (diff)
  • Priority changed from normal to highest
  • Resolution fixed deleted
  • Severity changed from normal to blocker
  • Status changed from closed to reopened
  • Version changed from 4.7.3 to 4.9.1

comment:7 Changed on Apr 25, 2016 at 11:50:59 PM by rblaa

I tried using 4.9.1 and now 5.0 on a Mac, this issue is now happening to me: files transfer fine, but the first directory fails with "Transfer Incomplete" error.

This is preventing me from being able to upload my directory to S3.

comment:8 Changed on Apr 26, 2016 at 12:03:54 AM by rblaa

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed on Apr 26, 2016 at 12:04:22 AM by rblaa

I closed this ticket again, and will reopen another. It is most likely that the reason for my error is different.

Note: See TracTickets for help on using tickets.
swiss made software