Cyberduck Mountain Duck CLI

#9214 closed defect (duplicate)

Download to... fails to replace files

Reported by: Xaero182 Owned by:
Priority: normal Milestone: 4.8
Component: core Version: 4.7.3
Severity: normal Keywords: download
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by Xaero182)

When using the "download to..." file option to download a set of files to the local file system, it only works when these files are not yet present.

Steps to reproduce:

  1. create a temp dir locally
  2. open cyberduck and login to server using sftp (I'm using a public/private key mechanism)
  3. select a file and click "Download to..." in the context menu
  4. download the file to temp dir
  5. check that they are actually there
  6. redo steps 3 and 4
  7. click overwrite in the dialog
  8. observe that original downloaded files are gone

Log drawer content after these steps:

1 OPENDIR
2 READDIR
3 READDIR
4 CLOSE
5 OPEN
6 READ
7 READ
8 READ
9 READ
10 CLOSE
1 OPENDIR
2 READDIR
3 READDIR
4 CLOSE
5 OPEN
6 READ
7 READ
8 READ
9 READ
10 CLOSE

Change History (9)

comment:1 Changed on Jan 17, 2016 at 3:39:42 PM by Xaero182

  • Description modified (diff)

comment:2 Changed on Jan 18, 2016 at 4:47:11 PM by dkocher

  • Milestone set to 4.8
  • Resolution set to fixed
  • Status changed from new to closed

Please update to the latest snapshot build available. Duplicate for #9130.

comment:3 Changed on Jan 19, 2016 at 1:21:37 PM by Xaero182

Not fixed in 4.8

comment:4 Changed on Jan 19, 2016 at 1:58:40 PM by dkocher

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Download to... fails over sftp to Download to... fails to replace files

comment:5 Changed on Jan 19, 2016 at 3:07:14 PM by dkocher

Which build are you running? I still cannot reproduce the error here.

comment:6 Changed on Jan 19, 2016 at 4:21:04 PM by Xaero182

Version 4.8.0 (18667)

comment:7 Changed on Jan 21, 2016 at 1:20:07 PM by dkocher

  • Resolution set to duplicate
  • Status changed from reopened to closed

In r19157.

comment:8 Changed on Jan 21, 2016 at 1:58:09 PM by dkocher

Please update to the latest snapshot build available.

comment:9 Changed on Jan 25, 2016 at 9:25:44 AM by Xaero182

Not solved in Version 4.8.0 (18783)

Note: See TracTickets for help on using tickets.