Cyberduck Mountain Duck CLI

#9223 closed defect (fixed)

Uploads of large objects to Oracle Storage Cloud Service fail with 400 error reply

Reported by: ukaushik Owned by: dkocher
Priority: high Milestone: 5.0
Component: openstack Version: 4.7.3
Severity: major Keywords: Oracle Cloud Storage Service OSS
Cc: Architecture:
Platform: Mac OS X 10.11

Description

We were trying to certify Cyberduck with Oracle Storage Cloud Services and found out that for smaller object uploads works fine, but larger objects, typically > 3GB uploads always fails with an error to retry/continue. From our systems only about 1 GB file uploads worked successfully. Our work flow demands upwards of 50 to 60 GB single file/object upload to be successful, which unfortunately we have not had luck with.

A large object download also gave up problems (about 10 GB).

Change History (15)

comment:1 Changed on Jan 21, 2016 at 2:10:10 PM by dkocher

Possibly related to #9131. Although this ticket only affect files greater than 100GB.

comment:2 Changed on Jan 21, 2016 at 2:15:59 PM by dkocher

Please post the transcript from the log drawer of the Transfers window. Choose ⌘-L on Mac or right-click the toolbar from the Transfers window and choose Log on Windows

comment:3 Changed on Jan 21, 2016 at 4:23:55 PM by dkocher

Please update to the latest snapshot build available when testing again.

comment:4 Changed on Jan 22, 2016 at 11:37:31 PM by dkocher

  • Milestone set to 4.8
  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed on Jan 23, 2016 at 12:26:22 AM by ukaushik

There was nothing logged to the console/window when I try the upload of a 3.2 GB file. I get a screen that pops up that says the command failed and gives me an option to continue. And if I do, it retries the upload and fails.

The upload never succeeds.

comment:6 Changed on Jan 23, 2016 at 12:29:59 AM by ukaushik

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:7 Changed on Jan 29, 2016 at 10:23:42 AM by dkocher

Surely the transfer log drawer contains the HTTP transcript. Please attach.

comment:8 Changed on Jan 29, 2016 at 10:32:56 AM by dkocher

Would it be possibly to activate our identity domain again [1] which would allow us to assist you in testing.

[1] Identity Domain: chiterategmbhtrial85243

comment:9 Changed on Feb 11, 2016 at 5:22:33 PM by dkocher

  • Resolution set to thirdparty
  • Status changed from reopened to closed

Handled in case CD-52.

comment:10 Changed on May 23, 2016 at 8:14:18 AM by dkocher

  • Milestone changed from 4.8 to 5.0
  • Summary changed from Uploads of large objects to Oracle Storage Cloud Service to Uploads of large objects to Oracle Storage Cloud Service fail with 400 error reply

comment:11 Changed on May 24, 2016 at 10:14:48 AM by dkocher

Fixed stream progress reset in r20691 for failed segments.

comment:12 Changed on May 24, 2016 at 11:57:15 AM by dkocher

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

comment:13 Changed on May 24, 2016 at 12:02:26 PM by dkocher

The issue is caused by URI encoded forward slashes in the object name.

comment:14 Changed on May 24, 2016 at 12:05:17 PM by dkocher

Added test in r20698.

comment:15 Changed on May 24, 2016 at 12:15:10 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Fix in r20699 from upstream changeset.

Note: See TracTickets for help on using tickets.
swiss made software