Cyberduck Mountain Duck CLI

#9238 closed defect (worksforme)

Timeout for transfer when limiting bandwidth

Reported by: triggs Owned by: dkocher
Priority: normal Milestone:
Component: sftp Version: 4.7.3
Severity: normal Keywords: timeout manually reduced bandwidth
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description

I am using the SFTP connection. When I leave the bandwidth set to Unlimited everything goes fine, but whenever I manually limit the bandwidth (I use the dropdown selector in the Transfer window) the download will eventually time out. It doesn't happen right away, and may take an hour or more. I can even set the bandwidth limit to something at or above what I am actually seeing and it will still time out.

I've tried searching for suggestions, but am having a hard time locating a similar issue being discussed. I don't always want to transfer as fast as my connection will allow. Are you aware of this issue, or have any suggestions on what to try?

Change History (2)

comment:1 Changed on Feb 1, 2016 at 9:40:57 AM by dkocher

  • Component changed from core to sftp
  • Owner set to dkocher
  • Summary changed from Timeout When I Manually Limit Bandwidth to Timeout for transfer when limiting bandwidth

comment:2 Changed on Feb 15, 2016 at 1:55:31 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I tested here with limiting an SFTP download to 50KB/s but cannot reproduce the issue. It appears to me this is possibly an issue with the server dropping the connection for unknown reasons.

Note: See TracTickets for help on using tickets.