Cyberduck Mountain Duck CLI

#9241 closed defect (fixed)

Overwriting an existing downloaded file causes it to be deleted locally

Reported by: cmoore Owned by: dkocher
Priority: high Milestone: 4.8
Component: ftp Version: 4.7.3
Severity: major Keywords: download overwrite
Cc: cmoore716@… Architecture:
Platform: Mac OS X 10.11

Description

Within the past month, a strange bug has occurred in CyberDuck. I select a file to download and drag it from Cyberduck to my folder in Mac finder. If that file already exists in the finder location, I get the option to overwrite, rename, skip, etc. In the past, I always choose overwrite, and the local file gets replaced with the newly downloaded one. Now the existing file I want to be overwritten gets deleted and no file is downloaded at all.

I've uninstalled and reinstalled the app, but it doesn't seem to change anything. Help? To my knowledge, I haven't updated the program recently or before this issue started appearing. I also purchased CyberDuck through the Mac OS App store.

Attachments (1)

Screen Shot 2016-02-03 at 3.29.54 PM.png (140.8 KB) - added by cmoore on Feb 3, 2016 at 9:31:30 PM.
missing update tab

Download all attachments as: .zip

Change History (9)

comment:1 Changed on Feb 3, 2016 at 9:21:27 PM by cmoore

  • Cc cmoore716@… added
  • Component changed from core to ftp
  • Owner set to dkocher
  • Priority changed from normal to high
  • Severity changed from normal to major

comment:2 Changed on Feb 3, 2016 at 9:24:36 PM by dkocher

This bug should be fixed in the latest snapshot build. Please update to the latest snapshot build available and confirm.

comment:3 Changed on Feb 3, 2016 at 9:24:43 PM by dkocher

  • Milestone set to 4.8

Changed on Feb 3, 2016 at 9:31:30 PM by cmoore

missing update tab

comment:4 Changed on Feb 3, 2016 at 9:32:54 PM by cmoore

I don't have the update tab in my preferences menu. Please see Screen Shot 2016-02-03 at 3.29.54 PM.png​ attached

comment:5 Changed on Feb 3, 2016 at 9:51:16 PM by dkocher

Can you download the snapshot from https://update.cyberduck.io/nightly/Cyberduck-4.8.18836.zip as you are running Cyberduck purchased from the Mac App Store.

comment:6 Changed on Feb 3, 2016 at 9:51:56 PM by rwhalen

I have this same issue. I've just updated to the latest snapshot release and it does not appear to have addressed it. When I drag a file from the server to a directory on my local machine (OSX 10.11.3) and select 'Overwrite' it will instead delete the file.

comment:7 Changed on Feb 3, 2016 at 11:17:41 PM by cmoore

Still not working for me either with the latest snapshot build. I tried to overwrite a file, and it got deleted.

comment:8 Changed on Feb 5, 2016 at 8:11:18 AM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

Fix in r19275.

Note: See TracTickets for help on using tickets.