Cyberduck Mountain Duck CLI

#9287 closed defect (worksforme)

Profile installation fails on network drive accessed through Active Directory

Reported by: alastair.smith@… Owned by: yla
Priority: normal Milestone: 4.8
Component: core Version: 4.7.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

Hi I work in University College London, Research Data Services.

We are recommending cyberduck as a GUI based client for our new iRODS system.

We had a user that ran into difficulty on an institutional machine running Windows 7 Enterprise

double clicking the file.cyberduckprofile file that we customized didn't appear to do anything for the user.

I can see that on my own machine inside %APPDATA%\Roaming\Cyberduck\ It creates a Profiles folder and copies the profile file into it.

Our user had a different setup where %APPDATA% was on a network drive accessed through Active Directory

%APPDATA% resolved to
ad.ucl.ac.uk\home\<username>\AppData\

no Profiles folder was created in this case. I don't actually know if this difference was the cause of the issue though.

By manually copying the profile file over to the
ad.ucl.ac.uk\home\<username>\AppData\Roaming\Cyberduck\Profiles directory from his computer, we were able to get cyberduck to accept the irods profile that we created.

Perhaps this occurs due to a false assumption made about the nature of the directory path that must be copied to when a profile is installed?

If you have some questions, I might be able to feed them through to our user.

Many thanks and thanks for making a great product!

Alastair

Change History (3)

comment:1 Changed on Feb 19, 2016 at 9:07:02 PM by dkocher

  • Milestone set to 4.8
  • Owner set to yla
  • Summary changed from issue with profile install to Profile installation fails on network drive accessed through Active Directory

comment:2 Changed on Feb 22, 2016 at 4:26:05 PM by yla

What about the other folders in ad.ucl.ac.uk\home\<username>\AppData\Roaming\Cyberduck such as Bookmarks or Transfers? Do they exist?

We use the standard .NET method to find the path: Environment.GetFolderPath(Environment.SpecialFolder.ApplicationData). What does

echo %APPDATA%

returns when executing in command prompt window? Do you get ad.ucl.ac.uk or \\ad.ucl.ac.uk?

comment:3 Changed on Feb 23, 2016 at 8:16:56 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software