Cyberduck Mountain Duck CLI

#9310 closed defect (fixed)

Failed huge file upload to Hubic with command line interface

Reported by: tedjasudu Owned by: dkocher
Priority: normal Milestone: 4.8.3
Component: openstack Version: 4.7.3
Severity: normal Keywords: duck
Cc: Architecture:
Platform:

Description (last modified by dkocher)

Server: CentOs 7

When try to upload huge file (250G) to Hubic upload fails after 2 reconnects. For example - uploads 45Gb, error connection, after this first reconnect good, but second fails with error;

Transfer incomplete…log4j:WARN No appenders could be found for logger (ch.cyberduck.core.threading.SessionBackgroundAction).
log4j:WARN Please initialize the log4j system properly.
log4j:WARN See http://logging.apache.org/log4j/1.2/faq.html#noconfig for more info.

java.lang.Exception
        at ch.cyberduck.core.threading.BackgroundCallable.<init>(BackgroundCallable.java:25)
        at ch.cyberduck.core.AbstractController.background(AbstractController.java:106)
        at ch.cyberduck.cli.Terminal.execute(Terminal.java:452)
        at ch.cyberduck.cli.Terminal.transfer(Terminal.java:348)
        at ch.cyberduck.cli.Terminal.execute(Terminal.java:255)
        at ch.cyberduck.cli.Terminal.open(Terminal.java:150)
        at ch.cyberduck.cli.Terminal.main(Terminal.java:140)
Caused by: java.lang.NullPointerException
        at ch.cyberduck.core.openstack.SwiftLargeObjectUploadFeature.upload(SwiftLargeObjectUploadFeature.java:140)
        at ch.cyberduck.core.openstack.SwiftLargeObjectUploadFeature.upload(SwiftLargeObjectUploadFeature.java:56)
        at ch.cyberduck.core.openstack.SwiftThresholdUploadService.upload(SwiftThresholdUploadService.java:111)
        at ch.cyberduck.core.transfer.UploadTransfer.transfer(UploadTransfer.java:245)
        at ch.cyberduck.core.worker.AbstractTransferWorker$3.call(AbstractTransferWorker.java:382)
        at ch.cyberduck.core.worker.SingleTransferWorker.submit(SingleTransferWorker.java:84)
        at ch.cyberduck.core.worker.AbstractTransferWorker.transfer(AbstractTransferWorker.java:375)
        at ch.cyberduck.core.worker.AbstractTransferWorker.run(AbstractTransferWorker.java:237)
        at ch.cyberduck.core.worker.AbstractTransferWorker.run(AbstractTransferWorker.java:64)
        at ch.cyberduck.core.threading.WorkerBackgroundAction.run(WorkerBackgroundAction.java:110)
        at ch.cyberduck.core.threading.AbstractBackgroundAction.call(AbstractBackgroundAction.java:119)
        at ch.cyberduck.core.threading.SessionBackgroundAction.call(SessionBackgroundAction.java:184)
        at ch.cyberduck.core.threading.BackgroundCallable.call(BackgroundCallable.java:51)
        at java.util.concurrent.FutureTask.run(FutureTask.java:266)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
        at ch.cyberduck.core.threading.NamedThreadFactory$1.run(NamedThreadFactory.java:58)
        at java.lang.Thread.run(Thread.java:745)

Start with command

duck -u my_user -pmy_key --upload cyberduck://hubic@my_gateway/default/Backups/ /backup/huge_250G_file.raw --throttle 2097152 -e resume &

Change History (4)

comment:1 Changed on Feb 29, 2016 at 8:12:21 AM by dkocher

  • Description modified (diff)

comment:2 Changed on Feb 29, 2016 at 8:12:59 AM by dkocher

  • Milestone set to 5.0
  • Status changed from new to assigned
  • Summary changed from Failed huge file upload to Hubic with duck.sh to Failed huge file upload to Hubic with command line interface

comment:3 Changed on Feb 29, 2016 at 8:49:17 AM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r19484.

comment:4 Changed on Feb 29, 2016 at 8:53:05 AM by dkocher

  • Milestone changed from 5.0 to 4.8.3
Note: See TracTickets for help on using tickets.
swiss made software