Cyberduck Mountain Duck CLI

#9338 closed defect (worksforme)

Failure running script in Terminal. Application isn’t running

Reported by: davidott94 Owned by: dkocher
Priority: highest Milestone:
Component: sftp Version: 4.8.2
Severity: critical Keywords:
Cc: Architecture:
Platform:

Description

while being connected to a server using ssh sftp, I tried to open terminal.app and I got the error:

"Failure running script in Terminal. Application isn’t running. Please verify disk permissions."

Change History (9)

comment:1 Changed on Mar 4, 2016 at 2:51:32 PM by dkocher

Can you describe more verbosely what you are trying to do?

comment:2 Changed on Mar 4, 2016 at 2:52:38 PM by dkocher

Do you refer to the Open in Terminal feature?

comment:3 Changed on Mar 4, 2016 at 2:54:03 PM by dkocher

  • Summary changed from terminal.app not working to Failure running script in Terminal. Application isn’t running

comment:4 Changed on Mar 9, 2016 at 6:40:33 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed on Mar 10, 2016 at 3:41:21 PM by dkocher

Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:6 Changed on Mar 10, 2016 at 4:23:58 PM by davidott94

Apologies for my last comment, I mis understood. Here is the system.log output when I run the open in terminal.

Mar 10 11:22:10 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Mar 10 11:22:10 Davids-MacBook-Pro sandboxd[1381] ([13358]): Cyberduck(13358) deny appleevent-send com.apple.terminal
Mar 10 11:22:10 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal
Mar 10 11:22:10 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Mar 10 11:22:10 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal
Mar 10 11:22:10 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Mar 10 11:22:11 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal
Mar 10 11:22:11 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Mar 10 11:22:11 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal
Mar 10 11:22:11 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Mar 10 11:22:12 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal
Mar 10 11:22:12 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Mar 10 11:22:14 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal
Mar 10 11:22:14 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (___ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos
Last edited on Mar 10, 2016 at 4:30:02 PM by dkocher (previous) (diff)

comment:6 Changed on Mar 10, 2016 at 4:24:01 PM by davidott94

Apologies for my last comment, I mis understood. Here is the system.log output when I run the open in terminal.

Mar 10 11:22:10 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos Mar 10 11:22:10 Davids-MacBook-Pro sandboxd[1381] ([13358]): Cyberduck(13358) deny appleevent-send com.apple.terminal Mar 10 11:22:10 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal Mar 10 11:22:10 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos Mar 10 11:22:10 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal Mar 10 11:22:10 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos Mar 10 11:22:11 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal Mar 10 11:22:11 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos Mar 10 11:22:11 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal Mar 10 11:22:11 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos Mar 10 11:22:12 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal Mar 10 11:22:12 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos Mar 10 11:22:14 Davids-MacBook-Pro kernel[0]: Sandbox: Cyberduck(13358) deny(1) appleevent-send com.apple.terminal Mar 10 11:22:14 Davids-MacBook-Pro appleeventsd[51]: Sandboxed application with pid 13358 attempted to lookup App:"Terminal"/"com.apple.Terminal" 372/0x0:0x11011 ????1010 sess=100006 bundleID= but was denied due to sandboxing. (_ZL13handleMessageP17_xpc_connection_sPv_block_invoke264()/appleEventsD.cp #2474) com.apple.root.default-qos

comment:7 Changed on Mar 10, 2016 at 4:32:56 PM by dkocher

I assume you are running Cyberduck purchased from the Mac App Store which makes this a duplicate of #7664.

comment:8 Changed on Mar 10, 2016 at 4:40:22 PM by davidott94

Is there a documented example of resolving this issue using the NSUserscripttask?

Note: See TracTickets for help on using tickets.
swiss made software