Cyberduck Mountain Duck CLI

#9344 closed defect (worksforme)

File-read-data denied from PathFinder when running in sandbox

Reported by: jlolling Owned by: dkocher
Priority: normal Milestone: 4.8.4
Component: core Version: 4.8.2
Severity: normal Keywords: upload, pathfinder
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description (last modified by dkocher)

The upload failed with an error about permissions. If you try the same with drag and drop from the Finder it works well. I affects version 4.8.2 as well as 4.8.3

This is an example message from the log:
06/03/16 15:28:14,000 kernel[0]: Sandbox: Cyberduck(4724) deny(1) file-read-data /Volumes/Data/talend_palette.graphml
(in this case I tried 2 files and this is the second one).

Change History (7)

comment:1 Changed on Mar 6, 2016 at 2:31:37 PM by jlolling

  • Description modified (diff)

comment:2 Changed on Mar 9, 2016 at 9:31:39 AM by dkocher

  • Component changed from interface to core
  • Description modified (diff)

comment:3 Changed on Mar 9, 2016 at 9:34:24 AM by dkocher

Can you confirm you are running Cyberduck purchased from the Mac App Store.

comment:4 Changed on Mar 9, 2016 at 9:44:53 AM by jlolling

Yes, I can confirm, I have bought Cyberduck from the AppStore. My current version is: Version 4.8.3 (19083)

comment:5 Changed on Mar 9, 2016 at 10:53:02 AM by dkocher

  • Milestone set to 5.0
  • Status changed from new to assigned
  • Summary changed from Upload multiple files via drag and drop from PathFinder (Finder alternative) does not work to File-read-data denied from PathFinder when running in sandbox

comment:6 Changed on Mar 9, 2016 at 10:56:28 AM by dkocher

I am able to reproduce the issue with a multiple files selected and dragging to the browser window to upload. Single files do work however.

comment:7 Changed on Mar 16, 2016 at 2:00:29 PM by dkocher

  • Milestone changed from 5.0 to 4.8.4
  • Resolution set to worksforme
  • Status changed from assigned to closed

I just tried again and strangely can no longer reproduce the issue when running in a sandbox. Will reopen the ticket again if the issue reappears.

Note: See TracTickets for help on using tickets.
swiss made software