Cyberduck Mountain Duck CLI

#9358 closed defect (fixed)

Server certificate suddenly untrusted

Reported by: hurngchunlee Owned by: dkocher
Priority: high Milestone: 4.8.4
Component: webdav Version: 4.8
Severity: normal Keywords: WebDAV, SSL certificate verification
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description

Dear developers,

We are using Cyberduck with WebDAV (HTTP/SSL) protocol. Our server's hostname is "webdav.data.donders.ru.nl", and it has a valid certificate issued by a trusted CA. It has been working properly with Cyberduck 4.7.3, but since we upgrade to version 4.8.3, we encountered a failure during certificate trust verification. After some tests, we noticed that the same issue has been presented since version 4.8.

The error says that I might connect to a server pretending to be "data.donders.ru.nl". This is weird because we do connect to server "webdav.data.donders.ru.nl", and the server is totally independent to "data.donders.ru.nl" (in terms of DNS registry, in Web server configuration, and in certificate chain). We don't understand from where the "data.donders.ru.nl" is determined by the verification.

With a bit search in the existing tickets, I guess it might be something related to the fix of the ticket #3813.

Attached please find the screenshot of the error. Could you please help? Thank you very much in advance.

Cheers, Hong

Attachments (1)

Screen Shot 2016-03-10 at 09.10.03.png (366.3 KB) - added by hurngchunlee on Mar 10, 2016 at 8:32:10 AM.
screenshot of a failure during certificate trust verification

Download all attachments as: .zip

Change History (7)

Changed on Mar 10, 2016 at 8:32:10 AM by hurngchunlee

screenshot of a failure during certificate trust verification

comment:1 Changed on Mar 10, 2016 at 3:03:58 PM by dkocher

  • Milestone set to 5.0
  • Status changed from new to assigned
  • Summary changed from WebDAV server certificate suddenly untrusted after upgrading to 4.8.x to Server certificate suddenly untrusted

comment:2 Changed on Mar 10, 2016 at 3:09:17 PM by dkocher

Regression from r18562.

comment:3 Changed on Mar 10, 2016 at 3:42:39 PM by dkocher

  • Priority changed from normal to high

comment:4 Changed on Mar 10, 2016 at 4:36:11 PM by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

In r19611.

comment:5 Changed on Mar 10, 2016 at 9:01:17 PM by dkocher

  • Milestone changed from 5.0 to 4.8.4

comment:6 Changed on Mar 31, 2016 at 2:22:36 AM by matope

I'm from #9394 (duplication). I reproduce the same issue (except for I'm using S3 mode) on

4.8.1.19040
4.8.2.19063
4.8.3.19083
4.8.4.19355
5.0.19549 (snapshot build)

with Mac OS X El Capitan 10.11.4

It looks like this is not resolved on 4.8.4. Could you please check it out?

Note: See TracTickets for help on using tickets.
swiss made software