Cyberduck Mountain Duck CLI

#9394 closed defect (duplicate)

Certificate trust errors for S3

Reported by: matope Owned by:
Priority: normal Milestone: 4.8.4
Component: core Version: 4.8.1
Severity: normal Keywords: Certificate
Cc: Architecture:
Platform:

Description

Hi.

I'm using Cyberduck for Mac to access our s3-compatible storage system which is hosted by ourself.

With 4.8.1 or later version, we get certificate verification errors when we access SOME of our storage with Cyberduck S3 profile(With HTTPS).


For example:

domain.of.storage.system <- OK

the.other.domain.of.storage.system <- Error (OK for browser accesses)

The verification error say that hostname "the.other.domain.of.storage.system" is not "domain.of.storage.system".

I doubt that #3813 might be the cause of this issue. Especially LaxHostnameDelegatingTrustManager.setTarget() looks fishy for me. Could you please fix this issue?

Thank you.

Change History (2)

comment:1 Changed on Mar 30, 2016 at 12:48:40 PM by dkocher

  • Milestone set to 4.8.4
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 4.8.4 to 4.8.1

Duplicate for #9358. Please make sure you are running version 4.8.4.

comment:2 Changed on Mar 31, 2016 at 1:58:17 AM by matope

Sorry for the duplication. I've overlooked #9358. I'll continue on there.

Note: See TracTickets for help on using tickets.
swiss made software