Cyberduck Mountain Duck CLI

Opened 3 years ago

Closed 3 years ago

#9551 closed defect (worksforme)

Interoperability with IBM Bluemix Swift Object Storage

Reported by: kentstroker Owned by: dkocher
Priority: normal Milestone: 5.0
Component: openstack Version: 4.9.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

All the docs I can find show a very different credentials JSON doc and they terms used in your product do not align to IBM terms.

So, exactly how does one get this product to work; we have tried dozens of things and all fail. Below is a current service credentials example from Bluemix; which fields get used in your product to make a connection work?

We "think" it is project:username and password, but this fails.

Could use some accurate docs here to help please.

{
  "credentials": {
    "auth_url": "https://identity.open.softlayer.com",
    "project": "object_storage_........",
    "projectId": "9021b4ef334e4d7c82a5a441........",
    "region": "dallas",
    "userId": "bf81a4a2ec2848f8.........",
    "username": "Admin_e449219XXXXXXXXXXXXXXXca80a6f4209",
    "password": "D1111111111111111",
    "domainId": "63ccb0d5aa40463eb1408d09b45b89c4",
    "domainName": "947473"
  }
}

Change History (11)

comment:1 Changed 3 years ago by dkocher

  • Component changed from core to openstack
  • Milestone set to 5.0
  • Owner set to dkocher
  • Summary changed from IBM Bluemix Swift Object Storage to Interoperability with IBM Bluemix Swift Object Storage

comment:2 Changed 3 years ago by dkocher

  • Description modified (diff)

comment:3 Changed 3 years ago by dkocher

Could you please try with the documentation from Softlayer Object Storage.

comment:4 Changed 3 years ago by kentstroker

Yes, we saw that - that is Softlayer, we need a Bluemix solution. They are not the same thing. The JSON service credential is very different, these docs do not work. The downloads point to the wrong URL. Go out and get yourself a free Bluemix account, create a Swift Object, check out the service credentials file and see if you can get CyberDuck to work; if you can, post what fields you used from the Bluemix JSON document to get it working.

The problem is the way you folks use Tenant, Tenant ID, User and Password - this does not match the Bluemix Swift credentials and there are no docs to clearly tell you how to map the Bluemix credentials to the Cyberduck credentials. Terribly confusing and in the end, does not work. Perhapos you smart folks can find a way to get it to work and document it.

comment:5 Changed 3 years ago by dkocher

Thanks for the additional comments. We will do some interoperability testing here with an account. Could you also ping Bluemix Support for possible help in configuration.

comment:6 Changed 3 years ago by kentstroker

The issue is how you map Tenant ID: Access Key, Tenant and Secret from the Bluemix Service Credentials.

Bluemix Support has no information on this since your a 3rd party product. I can successfully use the Swift API to get athe my service, so I know Bluemix Swift is working and online. Testing Cloudberry now. Would like to see CyberDuck working.

comment:7 Changed 3 years ago by dkocher

Can you please try with the Keystone 3.0 profile as well.

comment:8 follow-up: Changed 3 years ago by kentstroker

That was successful, but had to do a bit of guessing as the matching the right parameters up. Well done.

The docs really need to be cleaned up and clearer; if we can work together I am happy to post this inside of IBM for Bluemix and other consumers to find and extooll the glories of your tool. I could also use a cyberduck sticker for my laptop... :)

So, can we author some better How to Use Cyberduck with Bluemix docs and get them out there?

comment:9 in reply to: ↑ 8 Changed 3 years ago by dkocher

Replying to kentstroker:

That was successful, but had to do a bit of guessing as the matching the right parameters up. Well done.

The docs really need to be cleaned up and clearer; if we can work together I am happy to post this inside of IBM for Bluemix and other consumers to find and extooll the glories of your tool. I could also use a cyberduck sticker for my laptop... :)

So, can we author some better How to Use Cyberduck with Bluemix docs and get them out there?

If you can share the bookmark I will defer a connection profile from it.

comment:10 Changed 3 years ago by dkocher

Documentation will be added in IBM Object Storage for Bluemix.

comment:11 Changed 3 years ago by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software