Cyberduck Mountain Duck CLI

#9569 closed enhancement (worksforme)

Delay when activating application

Reported by: meowtown Owned by:
Priority: normal Milestone: 5.3
Component: core Version: 5.0
Severity: normal Keywords: slow, switching
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description

I'm not sure if there's anything that can really be done about this, or what might be causing it but I've noticed since the last couple of updates cmd+tab seems to take almost a second to show when switching from another app.

A second might not seem long, but when you're doing live edits and repeatedly switching from your editor to Cyberduck, it gets a bit annoying after a while.

Change History (11)

comment:1 Changed on May 31, 2016 at 9:11:36 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this. Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:2 follow-up: Changed on Jun 11, 2016 at 10:33:36 PM by meowtown

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I see these messages mentioning Cyberduck, but I don't know if they're related:

2016-06-11 5:24:37.983 PM Cyberduck[8835]: NSWindow warning: adding an unknown subview: <NSButton: 0x7fda1e165120>. Break on NSLog to debug.

2016-06-11 5:24:37.984 PM Cyberduck[8835]: Call stack:
(
	0   AppKit                              0x00007fff87b424ef -[NSThemeFrame addSubview:] + 107
	1   libjnidispatch.dylib                0x000000011b5dc134 ffi_call_unix64 + 76
	2   ???                                 0x00007fff5b18f398 0x0 + 140734721749912
)



Last edited on Jun 14, 2016 at 12:54:37 PM by dkocher (previous) (diff)

comment:3 Changed on Jun 14, 2016 at 12:55:34 PM by dkocher

  • Summary changed from Slow cmd+tab switching since the last few updates to Delay when activating application

comment:4 Changed on Jun 28, 2016 at 6:20:18 PM by dkocher

  • Type changed from defect to enhancement

comment:5 Changed on Jul 23, 2016 at 10:30:25 PM by meowtown

Just a heads up, the latest version 5.0.9 has significantly improved the delay when switching apps. It's still noticeable but I'd say it's about 90% faster.

comment:6 Changed on Jul 24, 2016 at 7:16:36 PM by dkocher

  • Milestone set to 5.0.9
  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:7 Changed on Jul 28, 2016 at 2:05:21 AM by meowtown

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Unfortunately this appears to have progressively worsen since originally installing the update. I'm currently experiencing a delay of around ~1.7 switching between Cyberduck and any other app. It appears to be dramatically worse when 2 Cyberduck browsers are opened at once.

Last edited on Jul 28, 2016 at 2:05:44 AM by meowtown (previous) (diff)

comment:8 in reply to: ↑ 2 Changed on Oct 17, 2016 at 3:41:49 PM by dkocher

Replying to meowtown:

I see these messages mentioning Cyberduck, but I don't know if they're related:

2016-06-11 5:24:37.983 PM Cyberduck[8835]: NSWindow warning: adding an unknown subview: <NSButton: 0x7fda1e165120>. Break on NSLog to debug.

2016-06-11 5:24:37.984 PM Cyberduck[8835]: Call stack:
(
	0   AppKit                              0x00007fff87b424ef -[NSThemeFrame addSubview:] + 107
	1   libjnidispatch.dylib                0x000000011b5dc134 ffi_call_unix64 + 76
	2   ???                                 0x00007fff5b18f398 0x0 + 140734721749912
)



This warning got fixed in r21322. See #9554.

comment:9 Changed on Jan 10, 2017 at 10:58:31 AM by dkocher

#9753 closed as duplicate.

comment:10 Changed on Jan 10, 2017 at 10:58:56 AM by dkocher

Please try to remove previous transfers from the Transfers window to workaround this issue.

comment:11 Changed on Jan 13, 2017 at 2:11:53 PM by dkocher

  • Milestone changed from 5.0.9 to 5.3
  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.
swiss made software