Cyberduck Mountain Duck CLI

#9583 closed defect (worksforme)

Folder listing incomplete in browser when expanding a folder

Reported by: lofaro Owned by: dkocher
Priority: high Milestone: 5.3
Component: interface Version: 5.0.9
Severity: major Keywords: expand, list
Cc: laurent911te@… Architecture: Intel
Platform: Mac OS X 10.11

Description (last modified by lofaro)

Hi,

First of all, congratulations for the great piece of software Cyberduck you have built :) This is a great job !

I've just decided to create a ticket for the following issue because I've noticed that it hasn't been fixed during the multiple releases so far. Maybe no one else is affected but I can't really imagine it...

The issue is simple. After the connection is successfull, the view with all the files/folders is cut as soon as I expand a folder. There is one condition for this bug to happen: there must be enough files/folders to fill all the view and make a scrollbar appear.

For example, let's consider that I have 1 folder with 300 files inside on my server. First, I'm connecting to my server via Cyberduck and I see my folder closed. This is ok but now I want to expand it. So I click on the little horizontal arrow in front of it but only the 20 first files are shown (20 is an example to say that not all of them are shown) because I would need to scroll down to view the others. So far so good, except that the other files are not shown when I scroll down (the listing is cut by Cyberduck). When it happens, I need to close my folder and re-expand it, then I can scroll down and see all the 300 different files.

Thank you for your help and debugging. Laurent

Below is the result of the log drawer because you ask for it. This is different from my example but the issue is the same: the listing is cut after wp-config-sample.php in the visual interface whereas it is complete in the log drawer:

CWD /www
250 OK. Current directory is /www
TYPE A
200 TYPE is now ASCII
PASV
227 Entering Passive Mode (213,186,33,206,127,158)
MLSD
150 Accepted data connection
type=cdir;sizd=27;modify=20160506195840;UNIX.mode=0705;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba0; .
type=pdir;sizd=9;modify=20150910175738;UNIX.mode=0705;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81b9c; ..
type=file;size=12140;modify=20160413081053;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001g95b1862; .htaccess
type=file;size=176;modify=20140603220146;UNIX.mode=0604;UNIX.uid=87078;UNIX.gid=100;unique=100001gba80df; favicon.ico
type=file;size=53;modify=20140323221508;UNIX.mode=0604;UNIX.uid=87078;UNIX.gid=100;unique=100001g30a2b47; google06947efbdfe73f48.html
type=file;size=418;modify=20141218212259;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba2; index.php
type=file;size=19935;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba4; license.txt
type=dir;sizd=18;modify=20160605100732;UNIX.mode=0705;UNIX.uid=87078;UNIX.gid=100;unique=100001ga416f8a; logs_backwpup
type=file;size=7360;modify=20160506195840;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81bae; readme.html
type=file;size=237;modify=20140413083706;UNIX.mode=0604;UNIX.uid=87078;UNIX.gid=100;unique=100001ga001e11; robots.txt
type=file;size=5032;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81bad; wp-activate.php
type=dir;sizd=90;modify=20160413080627;UNIX.mode=0705;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81e64; wp-admin
type=file;size=364;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba9; wp-blog-header.php
type=file;size=1476;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba8; wp-comments-post.php
type=file;size=3568;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81baa; wp-config-sample.php
type=file;size=3493;modify=20141201185634;UNIX.mode=0400;UNIX.uid=87078;UNIX.gid=100;unique=100001g17238b67; wp-config.php
type=dir;sizd=12;modify=20160604205618;UNIX.mode=0705;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ffd; wp-content
type=file;size=3286;modify=20150831141252;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81bab; wp-cron.php
type=dir;sizd=162;modify=20160413080628;UNIX.mode=0705;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81baf; wp-includes
type=file;size=2380;modify=20141218212259;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba6; wp-links-opml.php
type=file;size=3316;modify=20151212213332;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba3; wp-load.php
type=file;size=33837;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd82b2c; wp-login.php
type=file;size=7887;modify=20151212213332;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81e63; wp-mail.php
type=file;size=13106;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81bac; wp-settings.php
type=file;size=28624;modify=20160413080628;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba1; wp-signup.php
type=file;size=4035;modify=20141218212259;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ba5; wp-trackback.php
type=file;size=3061;modify=20151212213332;UNIX.mode=0644;UNIX.uid=87078;UNIX.gid=100;unique=100001gd81ffc; xmlrpc.php
226-Options: -a -l 
226 27 matches total

Change History (14)

comment:1 Changed on Jun 5, 2016 at 5:54:28 PM by lofaro

  • Cc laurent911te@… added
  • Description modified (diff)

comment:2 Changed on Jun 6, 2016 at 7:52:46 AM by dkocher

  • Summary changed from File listing cut inside the GUI when expanding a folder to Folder listing incomplete in browser when expanding a folder

comment:3 Changed on Jun 8, 2016 at 1:11:30 PM by dkocher

I have never seen this bug myself. Can you find any related output in the system.log (/Applications/Utilities/Console.app)?

comment:4 Changed on Jun 13, 2016 at 9:07:33 AM by dbleisch

I have the same problem. Appears only as parts of the listing are not visible, because the listing is longer than the viewport. As soon as you open a subfolder with more content the none visible content has to be reloaded to be accessible when scrolling down. Have not found any related output at system.log. The bug existed also with older versions.

comment:5 follow-up: Changed on Jul 27, 2016 at 9:49:17 AM by dkocher

I cannot reproduce the issue here. Are you using the latest version of Cyberduck?

comment:6 in reply to: ↑ 5 Changed on Jul 27, 2016 at 2:01:00 PM by dbleisch

I'm using Version 5.0.9 (20675) on OSX 10.11.6. Error happened with most of the previous versions.

Last edited on Jul 27, 2016 at 2:01:14 PM by dbleisch (previous) (diff)

comment:7 follow-up: Changed on Jul 29, 2016 at 3:11:00 PM by lofaro

  • Version changed from 5.0 to 5.0.9

Hi,

I can confirm that v5.0.9 (20675) has still the issue. More, as requested, you may find below the related output in Console:

29/07/2016 16:18:43,789 Cyberduck[22189]: NSWindow warning: adding an unknown subview: <NSButton: 0x7fcc19ecc350>. Break on NSLog to debug.
29/07/2016 16:18:43,790 Cyberduck[22189]: Call stack:
(
	0   AppKit                              0x00007fff8f1127b7 -[NSThemeFrame addSubview:] + 107
	1   libjnidispatch.dylib                0x0000000127468134 ffi_call_unix64 + 76
	2   ???                                 0x00007fff52cf3518 0x0 + 140734582699288
)

I hope it helps :) Best regards, JL

comment:8 in reply to: ↑ 7 Changed on Oct 17, 2016 at 3:41:27 PM by dkocher

Replying to lofaro:

Hi,

I can confirm that v5.0.9 (20675) has still the issue. More, as requested, you may find below the related output in Console:

29/07/2016 16:18:43,789 Cyberduck[22189]: NSWindow warning: adding an unknown subview: <NSButton: 0x7fcc19ecc350>. Break on NSLog to debug.
29/07/2016 16:18:43,790 Cyberduck[22189]: Call stack:
(
	0   AppKit                              0x00007fff8f1127b7 -[NSThemeFrame addSubview:] + 107
	1   libjnidispatch.dylib                0x0000000127468134 ffi_call_unix64 + 76
	2   ???                                 0x00007fff52cf3518 0x0 + 140734582699288
)

I hope it helps :) Best regards, JL

This warning got fixed in r21322. See #9554.

comment:9 follow-up: Changed on Nov 8, 2016 at 9:14:56 AM by dbleisch

I think this is fixed now: Version 5.2.2 (21483)

comment:10 Changed on Nov 8, 2016 at 3:40:38 PM by dkocher

  • Milestone set to 5.2
  • Resolution set to worksforme
  • Status changed from new to closed

As I could never reproduce this issue here I will close it. Please reopen if you encounter this bug again.

comment:11 Changed on Nov 8, 2016 at 10:20:40 PM by lofaro

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:12 in reply to: ↑ 9 Changed on Nov 8, 2016 at 10:23:13 PM by lofaro

Replying to dbleisch:

I think this is fixed now: Version 5.2.2 (21483)

Hello,

I've just tested with version 5.2.2 and I can confirm this is NOT fixed. The issue is still the same. I reopen this ticket then.

Best regards,

comment:13 Changed on Jan 16, 2017 at 1:38:36 PM by dkocher

  • Milestone changed from 5.2 to 5.3
  • Resolution set to worksforme
  • Status changed from reopened to closed

Please reopen this issue if you can still reproduce with the current 5.3 snapshot build.

comment:14 Changed on Jan 26, 2017 at 4:21:02 PM by lofaro

A priori, I cannot reproduce the problem with Cyberduck 5.3.3 (23221). Can you confirm that you changed something? Thank you.

Note: See TracTickets for help on using tickets.
swiss made software