Cyberduck Mountain Duck CLI

#9595 closed defect (worksforme)

Autoupdate denied since it was quarantined by Cyberduck and not approved by Gatekeeper

Reported by: chesteap Owned by:
Priority: normal Milestone:
Component: core Version: 5.0
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description (last modified by dkocher)

Hi,

Here is the error in system.log

Jun 14 16:09:37 TonyMac Cyberduck[1403]: Sparkle: ===== Cyberduck =====
Jun 14 16:09:37 TonyMac Cyberduck[1403]: Sparkle: Extracting using '/usr/bin/ditto' '-x' '-k' '-' < '/Users/tonychester/Library/Containers/ch.sudo.cyberduck/Data/Library/Caches/ch.sudo.cyberduck/Sparkle/Cyberduck 20379 2/Cyberduck-5.0.1.20379.zip' '/Users/tonychester/Library/Containers/ch.sudo.cyberduck/Data/Library/Caches/ch.sudo.cyberduck/Sparkle/Cyberduck 20379 2'
Jun 14 16:10:08 TonyMac Cyberduck[1403]: Sparkle: Failed to release quarantine on /Users/tonychester/Library/Containers/ch.sudo.cyberduck/Data/Library/Caches/ch.sudo.cyberduck/Sparkle/Autoupdate.app with error Error Domain=NSPOSIXErrorDomain Code=1 "Failed to remove file quarantine on Autoupdate.app." UserInfo=0x600001c6b940 {NSLocalizedDescription=Failed to remove file quarantine on Autoupdate.app.}
Jun 14 16:10:08 TonyMac kernel[0]: exec of /Users/tonychester/Library/Containers/ch.sudo.cyberduck/Data/Library/Caches/ch.sudo.cyberduck/Sparkle/Autoupdate.app/Contents/MacOS/Autoupdate denied since it was quarantined by Cyberduck and not approved by Gatekeeper, qtn-flags was 0x00000002
Jun 14 16:10:08 TonyMac Cyberduck[1403]: Couldn't posix_spawn: error 1
Jun 14 16:10:08 TonyMac Cyberduck[1403]: (
                0   CoreFoundation                      0x00007fff8509403c __exceptionPreprocess + 172
                1   libobjc.A.dylib                     0x00007fff814b876e objc_exception_throw + 43
                2   CoreFoundation                      0x00007fff85093eed +[NSException raise:format:] + 205
                3   Foundation                          0x00007fff8cb0ac8f -[NSConcreteTask launchWithDictionary:] + 3119
                4   Foundation                          0x00007fff8ccb3229 +[NSTask launchedTaskWithLaunchPath:arguments:] + 194
                5   Sparkle                             0x00000001030495e6 -[SUBasicUpdateDriver installWithToolAndRelaunch:displayingUserInterface:] + 3956
                6   Sparkle                             0x000000010305eeb7 -[SUUIBasedUpdateDriver installWithToolAndRelaunch:] + 400
                7   libsystem_trace.dylib               0x00007fff8ec22cd7 _os_activity_initiate + 75
                8   AppKit                              0x00007fff822aaeb1 -[NSApplication sendAction:to:from:] + 452
                9   AppKit                              0x00007fff822c0946 -[NSControl sendAction:to:] + 86
                10  AppKit                              0x00007fff822c0862 __26-[NSCell _sendActionFrom:]_block_invoke + 131
                11  libsystem_trace.dylib               0x00007fff8ec22cd7 _os_activity_initiate + 75
                12  AppKit                              0x00007fff822c07bf -[NSCell _sendActionFrom:] + 144
                13  libsystem_trace.dylib               0x00007fff8ec22cd7 _os_activity_initiate + 75
                14  AppKit                              0x00007fff822becb3 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 
2821
                15  AppKit                              0x00007fff8231734f -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 770
                16  AppKit                              0x00007fff822bd366 -[NSControl mouseDown:] + 714
 17  AppKit                              0x00007fff828272dc -[NSWindow _reallySendEvent:isDelayedEvent:] + 14125
                18  AppKit                              0x00007fff821b6c86 -[NSWindow sendEvent:] + 470
                19  AppKit                              0x00007fff821b3212 -[NSApplication sendEvent:] + 2504
                20  AppKit                              0x00007fff820dcb68 -[NSApplication run] + 711
                21  libjnidispatch.dylib                0x000000011c3d0134 ffi_call_unix64 + 76
                22  ???                                 0x00007fff5cbe2318 0x0 + 140734749352728
        )

Change History (3)

comment:1 Changed on Jun 14, 2016 at 3:44:06 PM by dkocher

  • Description modified (diff)

comment:2 Changed on Jun 14, 2016 at 3:44:45 PM by dkocher

  • Summary changed from Cannot Update Cyberduck to Autoupdate denied since it was quarantined by Cyberduck and not approved by Gatekeeper

comment:3 Changed on Jun 16, 2016 at 11:44:54 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I can only suggest to download manually from https://cyberduck.io. There seems to be an issue on your system to unset the quarantine flag but I am unable to reproduce this here.

Note: See TracTickets for help on using tickets.
swiss made software