Cyberduck Mountain Duck CLI

#9612 closed defect (worksforme)

Exception connecting to bookmark with whitespace in default path

Reported by: user8439 Owned by: dkocher
Priority: normal Milestone: 5.0.11
Component: interface Version: 5.0.9
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 7

Description (last modified by dkocher)

Steps to reproduce:

  1. Connect to an iRODS Zone using the iRODS protocol
  2. Navigate to a collection in the Browser
  3. With a collection highlighted in the Browser, press CTRL+SHIFT+B to create a new bookmark
  4. Assign a Nickname in the resulting new bookmark dialog, observing that the Path field now includes the path to the collection
  5. Close the new bookmark dialog
  6. Double-click the new bookmark from the Bookmarks list
  7. An error dialog is generated, reporting:
   "Connection failed
    Cannot convert this account into a URI:irods://..."

Test environment:

  • Cyberduck 5.0.3 on Microsoft Windows 7 Enterprise Service Pack 1 64-bit
  • iRODS server Release Version rods4.1.6, API Version = d

Attachments (4)

Ticket9612.cyberduckprofile (911 bytes) - added by user8439 on Jul 15, 2016 at 3:08:36 PM.
Profile
f66b7c34-ae4c-4293-afc9-2a1e735892f4.duck (914 bytes) - added by user8439 on Jul 15, 2016 at 3:14:03 PM.
Bookmark
Capture.PNG (14.9 KB) - added by user8439 on Jul 27, 2016 at 4:57:38 PM.
Error message
About Cyberduck.PNG (44.6 KB) - added by user8439 on Jul 28, 2016 at 3:14:09 PM.

Download all attachments as: .zip

Change History (34)

comment:1 Changed on Jun 30, 2016 at 6:07:59 PM by dkocher

  • Milestone set to 5.1
  • Owner set to dkocher
  • Status changed from new to assigned
  • Summary changed from Unable to bookmark a specific collection in iRODS to Unable to bookmark a specific collection

comment:2 Changed on Jun 30, 2016 at 8:58:51 PM by user8439

Note that this issue also seems to appear when Preferences, General, Browser, Save Workspace is checked. In that case, closing Cyberduck from an active iRODS connection and restarting it will produce the connection failed error at startup.

comment:3 follow-up: Changed on Jul 1, 2016 at 7:31:57 AM by dkocher

Can you please attach the connection profile you are using. If you have multiple profiles installed, make sure the Vendor is different for each.

Last edited on Jul 1, 2016 at 8:33:35 AM by dkocher (previous) (diff)

comment:4 follow-up: Changed on Jul 1, 2016 at 7:45:37 PM by dkocher

Looks similar to this upstream issue.

comment:5 Changed on Jul 1, 2016 at 7:49:34 PM by dkocher

I cannot reproduce this error.

comment:6 Changed on Jul 4, 2016 at 6:49:34 AM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:7 in reply to: ↑ 4 Changed on Jul 6, 2016 at 2:10:12 PM by user8439

Replying to dkocher:

Looks similar to this upstream issue.

Test test environment is using iRODS 4.1.6 which appears to include the patch for upstream issue 48.

comment:8 in reply to: ↑ 3 Changed on Jul 6, 2016 at 2:12:33 PM by user8439

Replying to dkocher:

Can you please attach the connection profile you are using. If you have multiple profiles installed, make sure the Vendor is different for each.

I verified that this behavior persists after ensuring the Vendor string is unique for the profile. That fix did work-around issue #9615, but did not fix the case of a bookmark having a path other than "/".

comment:9 Changed on Jul 15, 2016 at 7:45:47 AM by dkocher

  • Description modified (diff)
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:10 follow-up: Changed on Jul 15, 2016 at 7:48:50 AM by dkocher

Can you post the full error message starting with Cannot convert this account into a URI:irods://….

comment:11 Changed on Jul 15, 2016 at 8:02:09 AM by dkocher

Can you please attach the connection profile and the bookmark created from the profile with the custom path.

comment:12 in reply to: ↑ 10 Changed on Jul 15, 2016 at 2:51:08 PM by user8439

Replying to dkocher:

Can you post the full error message starting with Cannot convert this account into a URI:irods://….

"Cannot convert this account into a URI:irods://user8439@irods.test.com:1247."

Last edited on Jul 15, 2016 at 3:16:54 PM by user8439 (previous) (diff)

Changed on Jul 15, 2016 at 3:08:36 PM by user8439

Profile

Changed on Jul 15, 2016 at 3:14:03 PM by user8439

Bookmark

comment:13 Changed on Jul 15, 2016 at 3:20:07 PM by user8439

I found that I could get the bookmark to work as expected in the case of the collection path not having any spaces in it. It seems that if I bookmark a path that does have a space in a collection name, then I do get the behavior described in this ticket. Perhaps this issue is limited only to the case of bookmarks containing spaces in the path?

comment:14 Changed on Jul 15, 2016 at 3:32:41 PM by dkocher

  • Summary changed from Unable to bookmark a specific collection to Exception connecting to bookmark with whitespace in default path

comment:15 Changed on Jul 18, 2016 at 7:57:54 AM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

In r21111.

comment:16 Changed on Jul 18, 2016 at 7:58:19 AM by dkocher

Upstream issue #189.

comment:17 Changed on Jul 19, 2016 at 9:20:05 AM by dkocher

  • Milestone changed from 5.1 to 5.0.9

comment:18 Changed on Jul 25, 2016 at 2:54:55 PM by user8439

  • Resolution fixed deleted
  • Status changed from closed to reopened

This issue persists in release 5.0.9.

comment:19 Changed on Jul 26, 2016 at 8:51:22 AM by dkocher

  • Milestone changed from 5.0.9 to 5.1
  • Version changed from 5.0.3 to 5.0.9

comment:20 Changed on Jul 27, 2016 at 9:51:40 AM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

I cannot reproduce the error anymore. What is the error message displayed?

Changed on Jul 27, 2016 at 4:57:38 PM by user8439

Error message

comment:21 Changed on Jul 27, 2016 at 4:58:19 PM by user8439

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have attached a screenshot with the error message.

comment:22 Changed on Jul 28, 2016 at 1:06:22 PM by dkocher

Can you verify again you are running version 5.0.9 on Windows?

Changed on Jul 28, 2016 at 3:14:09 PM by user8439

comment:23 Changed on Jul 28, 2016 at 3:15:57 PM by user8439

I have attached a screenshot of the About dialog in the Cyberduck instance used for testing. It reports Version 5.0.9 (20675) and is running on a Microsoft Windows 7 Enterprise Service Pack 1 64-bit Operating System.

comment:24 Changed on Jul 31, 2016 at 6:54:09 PM by dkocher

Please let me know the exact steps to follow to reproduce the issue.

comment:25 Changed on Jul 31, 2016 at 6:54:22 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:26 Changed on Aug 4, 2016 at 2:13:48 PM by mihondo

  • Component changed from irods to interface
  • Resolution worksforme deleted
  • Status changed from closed to reopened

Using Cyberduck V 5.1.0 (20676)

I reproduced the problem with spaces in bookmark paths for both iRODS /PAM and WebDAV connections. It appears that you are not encoding the path for the URL (spaces remain as spaces instead of %20)

Paths with folder names without spaces works; if the folder name has a space -- iRODS fails with

Connection failed /    Cannot convert this account into a URI:irods://..."

WebDAV fails with error below (position 63 is where the first space is).

[Window Title]
Error

[Main Instruction]
Connection failed

[Content]
Invalid redirect URI: http://rndsharepoint.dow.com/sites/IR/ripilot/ELNDeploy/Project Documents/Forms/AllItems.aspx. Illegal character in path at index 63: http://rndsharepoint.dow.com/sites/IR/ripilot/ELNDeploy'/Project Documents/Forms/AllItems.aspx.

In both cases, the URL that is showning the dialog (and in the bookmark file) has spaces in it (not %20's) .

In the case of the sharepoint connection , this path works: /sites/IR/ripilot/ELNDeploy/

When I try to type a space as part of the path, the space does not appear unless I back arrow and re-insert it. That tells me it is suggesting that spaces are not acceptable. A single "&" is not shown in the URL but "&&" shows a single "&".

Last edited on Aug 22, 2016 at 8:06:47 AM by dkocher (previous) (diff)

comment:27 Changed on Aug 4, 2016 at 2:50:06 PM by mihondo

On the other hand... spaces in a folder name are handled properly in Google Drive.

comment:28 Changed on Aug 22, 2016 at 8:05:50 AM by dkocher

Replying to mihondo:

The issue with the Sharepoint server is a different server side error. The server rndsharepoint.dow.com is responding with a HTTP redirect with a URL that is not properly encoded and therefore invalid. Please check the transcript from the log drawer.

Last edited on Aug 22, 2016 at 8:06:07 AM by dkocher (previous) (diff)

comment:29 Changed on Aug 24, 2016 at 1:02:36 PM by dkocher

  • Milestone changed from 5.1 to 5.0.11
  • Resolution set to worksforme
  • Status changed from reopened to closed

I can no longer reproduce this issue with version 5.0.11 and snapshot build 5.1.0 (20852).

comment:30 Changed on Aug 24, 2016 at 1:32:09 PM by dkocher

Please share the bookmark that is still giving the failure on attempting to open a connection.

Note: See TracTickets for help on using tickets.
swiss made software