Cyberduck Mountain Duck CLI

#9619 closed enhancement (worksforme)

Interoperability with backslash (\) in key name

Reported by: eli-b Owned by:
Priority: low Milestone: 7.0
Component: s3 Version: 5.0.3
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Windows 8.1

Description

S3 keys that contain a backslash (\) are not displayed in the bucket at all. Other files in the same bucket, which don't have a backslash in their key, are displayed correctly.

It's worth noting that Windows files are not allowed to have backslashes in their names - could this be the cause of the issue?

In comparison, CloudBerry Explorer for Amazon S3 lists such files, but fails to download them (I opened a ticket over there too).

Change History (2)

comment:1 Changed on Jul 13, 2016 at 8:35:06 PM by dkocher

  • Priority changed from normal to low
  • Summary changed from Keys that contain a backslash (\) are not displayed in the bucket at all to Interoperability with backslash (\) in key name
  • Type changed from defect to enhancement

comment:2 Changed on Jun 4, 2019 at 7:35:48 PM by dkocher

  • Milestone set to 7.0
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.
swiss made software