Cyberduck Mountain Duck CLI

#9622 closed defect (duplicate)

Upload rate regularly decreases over time

Reported by: jimgoldstein Owned by:
Priority: normal Milestone: 5.1
Component: b2 Version: 5.0.3
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description

This has been happening ever since Cyberduck was released. I am using v5.1 (20632)... update today... and still the same results. As a result I've not been able to upload large files or large amount of files in a meaningful timeframe. This is true even being at Backblaze's office on multi gigabit connection. Talking to our team there is no reason for the decrease on our side.

Attached are screenshots of this progressive decline in speed. The screenshot names contain time stamps.

Attachments (1)

cyberduck_performance.zip (1.3 MB) - added by jimgoldstein on Jul 7, 2016 at 10:04:23 PM.

Download all attachments as: .zip

Change History (8)

Changed on Jul 7, 2016 at 10:04:23 PM by jimgoldstein

comment:1 Changed on Jul 15, 2016 at 11:00:46 AM by dkocher

  • Component changed from core to b2

comment:2 Changed on Jul 15, 2016 at 11:19:00 AM by dkocher

I just tried to reproduce with uploading a 6GB+ file to Backblaze B2 at constant ~8MB/s with no issues from our CI environment.

comment:3 Changed on Jul 15, 2016 at 11:19:14 AM by dkocher

  • Milestone set to 5.1
  • Resolution set to thirdparty
  • Status changed from new to closed

comment:4 Changed on Jul 15, 2016 at 11:20:31 AM by dkocher

Please contact Backblaze B2 support to look into your issue in-depth. We previously have seen this when they had an issue with their router configuration for requests from certain locations (AWS eu-west-1 region in this case).

comment:5 Changed on Jul 15, 2016 at 5:52:18 PM by jimgoldstein

  • Resolution thirdparty deleted
  • Status changed from closed to reopened

Per my notes I am doing this from the Backblaze office (I am an employee) and have already run this by the engineers and support directly. They've explicitly stated this is a Cyberduck side issue.

Not only does the speed decrease, but each time an upload is paused the amount uploaded resets to a lower amount than what was reported upload the previous session. . For example it says 2GB have been uploaded and I pause the upload... the next time I start it will start from 300MB vs 2GB (the starting amount of my last start) or some partial amount (ex 1.2GB) but never the full amount uploaded on the last session. This has been like a Ground Hogs Day the movie for the past 2 months. I've been trying to upload the same 8.9GB folder over this duration with new builds and the same thing keeps happening.

Jim

comment:6 Changed on Jul 27, 2016 at 10:01:28 AM by dkocher

  • Resolution set to duplicate
  • Status changed from reopened to closed

Closing as duplicate for #9598 where we will handle all large file upload issues with B2.

comment:7 Changed on Jul 30, 2016 at 8:43:29 PM by dkocher

Please update to snapshot build 5.1.20726 or later which should fix this issues with large uploads to B2. Refer to https://trac.cyberduck.io/wiki/help/en/howto/preferences#Update on how to update to a snapshot build.

Note: See TracTickets for help on using tickets.
swiss made software