Cyberduck Mountain Duck CLI

#9647 closed defect (worksforme)

Not able to anonymously directly connect to subfolder of s3.amazonaws.com

Reported by: andreashorn Owned by: dkocher
Priority: normal Milestone:
Component: s3 Version: 5.0.11
Severity: normal Keywords:
Cc: Architecture:
Platform: Mac OS X 10.11

Description

Dear Cyber/Mountainduck staff,

I recently purchased mountainduck to connect to a folder of the s3 bucket system which is available using an anonymous account (http://fcon_1000.projects.nitrc.org/indi/enhanced/sharing_neuro.html).

However, both Cyber and Mountainduck report errors when connecting to the folder directly. (The folder is under fcp-indi/data/Projects/RocklandSample on the s3.amazonaws.com). Strangely, if I connect to the s3 root with cyberduck and choose "Go to Folder..." and enter the folder, I can access it. A colleague told me that he could access the folder directly on a mac using an older version of CyberDuck. So I think there is a timeout issue when connecting to the folder directly.

It would be awesome to get feedback on this!

Best, Andy

Attachments (2)

Screen Shot 2016-08-09 at 17.49.20.png (111.7 KB) - added by dkocher on Aug 9, 2016 at 3:49:48 PM.
fcp-indi.s3.amazonaws.com – S3.duck (587 bytes) - added by dkocher on Aug 9, 2016 at 3:54:20 PM.

Download all attachments as: .zip

Change History (7)

comment:1 Changed on Aug 5, 2016 at 9:04:13 PM by dkocher

  • Component changed from core to s3
  • Owner set to dkocher

comment:2 Changed on Aug 9, 2016 at 3:50:09 PM by dkocher

I cannot reproduce this issue with below connection details.

comment:3 Changed on Aug 9, 2016 at 3:54:35 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

See attached a recommended bookmark configuration.

comment:4 Changed on Aug 9, 2016 at 3:56:06 PM by dkocher

Please let us know if you still see this issue with the latest snapshot build available for testing for macOS [1]. Please let us know if that resolves the bug reported.

[1] https://snapshots.mountainduck.io/Mountain%20Duck-1.5.0.4585.zip

comment:5 Changed on Aug 9, 2016 at 4:09:00 PM by andreashorn

With the newest snapshot, I got the same error ("Listing directory RocklandSample failed"). but when I clicked on "Retry" it suddenly worked. This was not the case before (had clicked Retry several times). Since I bought on the AppStore – how could I update to this snapshot?

This is already great! Thanks so much for your quick response & help!

Best, Andy

Note: See TracTickets for help on using tickets.