Cyberduck Mountain Duck CLI

#9652 closed defect (fixed)

s3: upload permissions settings are not obeyed

Reported by: blacktrash Owned by: dkocher
Priority: normal Milestone: 5.1
Component: s3 Version: Nightly Build
Severity: normal Keywords:
Cc: blacktrash@… Architecture: Intel
Platform: Mac OS X 10.10

Description

I have set my upload permissions to world readable by default for uploads. At least for s3 they are not obeyed anymore, but are the default private AWS settings, and I have to change them manually.

Attachments (3)

Upload Permissino Preferences.png (98.9 KB) - added by dkocher on Aug 19, 2016 at 8:40:20 AM.
S3 ACLs.png (48.1 KB) - added by dkocher on Aug 19, 2016 at 8:40:24 AM.
Screen Shot 2016-08-19 at 1.07.08 PM.png (787.2 KB) - added by blacktrash on Aug 19, 2016 at 12:12:37 PM.
s3 acl with nightly build

Download all attachments as: .zip

Change History (9)

Changed on Aug 19, 2016 at 8:40:24 AM by dkocher

comment:1 Changed on Aug 19, 2016 at 8:40:41 AM by dkocher

I cannot reproduce this issue. Attached a screenshot of my configuration in Preferences and the resulting ACLs set on a file uploaded.

comment:2 follow-up: Changed on Aug 19, 2016 at 8:40:48 AM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

Changed on Aug 19, 2016 at 12:12:37 PM by blacktrash

s3 acl with nightly build

comment:3 in reply to: ↑ 2 Changed on Aug 19, 2016 at 12:19:01 PM by blacktrash

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to dkocher: Good for you ;-) As you can see it does not work for me: https://trac.cyberduck.io/attachment/ticket/9652/Screen%20Shot%202016-08-19%20at%201.07.08%20PM.png

comment:4 Changed on Aug 19, 2016 at 12:27:20 PM by dkocher

  • Milestone set to 5.1
  • Owner set to dkocher
  • Status changed from reopened to new

Regression from r21208.

comment:5 follow-up: Changed on Aug 19, 2016 at 1:08:28 PM by dkocher

  • Resolution set to fixed
  • Status changed from new to closed

In r21275 followed by refactoring in r21276.

comment:6 in reply to: ↑ 5 Changed on Aug 20, 2016 at 10:43:01 AM by blacktrash

Replying to dkocher:

In r21275 followed by refactoring in r21276.

Confirming fix. Thank you.

Note: See TracTickets for help on using tickets.
swiss made software