Cyberduck Mountain Duck CLI

#9677 closed defect (worksforme)

Recursive search only works down one level

Reported by: Scoth42 Owned by: dkocher
Priority: normal Milestone: 5.2
Component: s3 Version: 5.1
Severity: normal Keywords:
Cc: Architecture:
Platform:

Description (last modified by dkocher)

I did some searching around and couldn't decide if this was intentional or not, so feel free to close this as such if it is.

Recursive searching only works one level deep. For example, if I have a path with some files that looks like:

/Bucket/Collections/Bob/Date1/SomeRecording1.wav
/Bucket/Collections/Bob/Date1/SomeRecording2.wav
/Bucket/Collections/Bob/Date1/SomeRecording3.wav
/Bucket/Collections/Bob/Date2/SomeRecording1.wav
/Bucket/Collections/Bob/Date2/SomeRecording2.wav
/Bucket/Collections/Bob/Date2/SomeRecording3.wav
/Bucket/Collections/Steve/Date1/SomeRecording1.wav
/Bucket/Collections/Steve/Date1/SomeRecording2.wav
/Bucket/Collections/Steve/Date1/SomeRecording3.wav
/Bucket/Collections/Steve/Date2/SomeRecording1.wav
/Bucket/Collections/Steve/Date2/SomeRecording2.wav
/Bucket/Collections/Steve/Date2/SomeRecording3.wav

If I drill down to the person's name and try to search, I'll get the expected resulting date folders that have contents that match. This is fine.

If I back up to a lower directory, however, and try searching no results will be found. Based on the time, logs, and status bars it seems like it's poking through the directories, but never returns any paths. This is preventing me from searching for matches among multiple directories. I couldn't sit in /Bucket and search on "SomeRecording1" and have it return all the directories that have that. I've tried expanding out the directories as much as I can in case that's related somehow, but I have too many files to practically expand it that far.

Here's a snippet of the logs. They're all basically like this as it walks through the tree. Apologies for the weird formatting, it wasn't including newlines properly.

  GET /?max-keys=1000&prefix=recordings%2FCollections%20-%20Broken%20Promise%2F7_1_2016%2F&delimiter=%2F HTTP/1.1
  Date: Wed, 31 Aug 2016 15:23:37 GMT
  x-amz-request-payer: requester
  x-amz-content-sha256: sha256 key  
  Host: bucket.s3.amazonaws.com
  x-amz-date: 20160831T152337Z
  Authorization: auth stuff
  Connection: Keep-Alive
  User-Agent: Cyberduck/5.2.0.20906 (Windows 10/10.0) (x86)
  HTTP/1.1 200 OK
  x-amz-id-2: amz id info
  x-amz-request-id: 1CDB3FEB58747DCA
  Date: Wed, 31 Aug 2016 15:23:38 GMT
  x-amz-bucket-region: us-east-1
  Content-Type: application/xml
  Transfer-Encoding: chunked
  Server: AmazonS3

Attachments (1)

Screen Shot 2016-10-17 at 16.11.50.png (119.7 KB) - added by dkocher on Oct 17, 2016 at 2:14:01 PM.

Download all attachments as: .zip

Change History (8)

comment:1 Changed on Sep 6, 2016 at 8:29:25 AM by dkocher

  • Description modified (diff)
  • Milestone set to 5.2
  • Owner set to dkocher
  • Status changed from new to assigned

comment:2 Changed on Sep 6, 2016 at 8:29:34 AM by dkocher

  • Summary changed from Recursive Searching only works down one level to Recursive search only works down one level

comment:3 Changed on Oct 5, 2016 at 1:39:23 PM by dkocher

  • Milestone changed from 5.2 to 5.1.3

Milestone renamed

comment:4 Changed on Oct 5, 2016 at 1:39:23 PM by dkocher

  • Milestone changed from 5.1.3 to 6.0

Ticket retargeted after milestone closed

comment:5 Changed on Oct 17, 2016 at 2:13:47 PM by dkocher

I cannot reproduce this issue. Can you please double check your search term. Note that it will only attempt the directories the first time you search but will subsequently use cached entries. You might need to Reload the browser view.

comment:6 Changed on Oct 17, 2016 at 2:14:09 PM by dkocher

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:7 Changed on Oct 19, 2016 at 2:17:19 PM by dkocher

  • Milestone changed from 6.0 to 5.2

Milestone renamed

Note: See TracTickets for help on using tickets.
swiss made software