Cyberduck Mountain Duck CLI

#9686 closed defect (fixed)

Listing bucket containing multipart uploads fails with error in ListMultipartUploadsResultHandler

Reported by: blacktrash Owned by:
Priority: high Milestone: 5.3
Component: s3 Version: Nightly Build
Severity: normal Keywords:
Cc: Architecture: Intel
Platform: Mac OS X 10.10

Description

When trying to open a bucket containing multipart uploads I get:

Upload some-bucket failed.

Failed to parse XML document with handler class org.jets3t.impl.rest.XmlResponsesSaxParser $ListMultipartUploadsResultHandler.

Note: I'm not trying to upload anything.

Change History (11)

comment:1 Changed on Sep 14, 2016 at 12:14:30 PM by dkocher

  • Milestone set to 5.2
  • Summary changed from s3: cannot enter buckets containing multipart uploads to Listing bucket containing multipart uploads fails with error in ListMultipartUploadsResultHandler

comment:2 Changed on Oct 5, 2016 at 1:39:23 PM by dkocher

  • Milestone changed from 5.2 to 5.1.3

Milestone renamed

comment:3 Changed on Oct 5, 2016 at 1:39:23 PM by dkocher

  • Milestone changed from 5.1.3 to 6.0

Ticket retargeted after milestone closed

comment:4 follow-up: Changed on Oct 17, 2016 at 1:37:26 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

We cannot reproduce this failure in tests. Do you have a bucket that is accessible for us so we can reproduce the failure?

comment:5 Changed on Oct 19, 2016 at 2:17:19 PM by dkocher

  • Milestone changed from 6.0 to 5.2

Milestone renamed

comment:6 in reply to: ↑ 4 ; follow-up: Changed on Dec 20, 2016 at 1:40:09 PM by blacktrash

Replying to dkocher:

We cannot reproduce this failure in tests. Do you have a bucket that is accessible for us so we can reproduce the failure?

I may be able to if I'm allowed to send you the permissions via PM or other private means. Would that be possible from your side?

comment:7 in reply to: ↑ 6 Changed on Dec 21, 2016 at 10:42:45 AM by dkocher

Replying to blacktrash:

Replying to dkocher:

We cannot reproduce this failure in tests. Do you have a bucket that is accessible for us so we can reproduce the failure?

I may be able to if I'm allowed to send you the permissions via PM or other private means. Would that be possible from your side?

Definitely. Please create an access token for an IAM user that you can revoke after testing. You can send the credentials to [support@cyberduck.io].

comment:8 Changed on Dec 21, 2016 at 10:43:03 AM by dkocher

  • Milestone changed from 5.2 to 6.0
  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:9 follow-up: Changed on Dec 21, 2016 at 4:17:26 PM by dkocher

  • Resolution set to fixed
  • Status changed from reopened to closed

Ignore XML parsing failures for invalid content from S3 in r23124.

comment:10 in reply to: ↑ 9 Changed on Dec 22, 2016 at 3:05:52 AM by blacktrash

Replying to dkocher:

Ignore XML parsing failures for invalid content from S3 in r23124.

Confirming fix. Thanks a bunch!

comment:11 Changed on Jan 11, 2017 at 8:33:37 AM by dkocher

  • Milestone changed from 6.0 to 5.3

Milestone renamed

Note: See TracTickets for help on using tickets.