Cyberduck Mountain Duck CLI

#9694 closed defect (duplicate)

AWS Signature V4 Default Breaks EMC ECS Connectivity

Reported by: jcrivera Owned by:
Priority: high Milestone: 5.1.3
Component: s3 Version: 5.1
Severity: normal Keywords: EMC, ECS, S3
Cc: Architecture:
Platform: Mac OS X 10.11

Description

Hello, I downloaded the latest version of Cyberduck but had to fall back to v 5.0.11 the new feature you added called "[Feature] Default to signature version AWS4 when connecting to third party S3 providers" is breaking S3 authentication to EMC's 3rd party S3 storage arrays - ECS.

The error returned is shown in the attached screenshot.

Can you please create a UI element that lets me specify the S3 signature version on a per-bookmark basis? I couldn't find out how to switch this in the options so I had to uninstall the new version of the software and go back to using an older version.

Attachments (1)

Screen Shot 2016-09-14 at 9.41.18 AM.png (214.6 KB) - added by jcrivera on Sep 14, 2016 at 3:42:25 PM.
Error Screenshot

Download all attachments as: .zip

Change History (3)

Changed on Sep 14, 2016 at 3:42:25 PM by jcrivera

Error Screenshot

comment:1 Changed on Sep 14, 2016 at 7:01:37 PM by dkocher

  • Component changed from core to s3
  • Milestone set to 5.2
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #9667. Please update to the latest snapshot build available and use the new AWS2 signature version connection profile .

comment:2 Changed on Oct 5, 2016 at 1:39:23 PM by dkocher

  • Milestone changed from 5.2 to 5.1.3

Milestone renamed

Note: See TracTickets for help on using tickets.
swiss made software