Cyberduck Mountain Duck CLI

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#974 closed defect (fixed)

File gets deleted on remote server if upload permissions are wrong.

Reported by: incidentist Owned by: dkocher
Priority: highest Milestone: 2.7.2
Component: core Version: 2.7
Severity: critical Keywords: permissions, uploading, delete
Cc: Architecture:


I opened a text file from a remote server, edited it and saved it. The transfer "failed" because I didn't have sufficient permissions. Indeed, I didn't -- I was in the group, but no write permissions, so I ssh'd in and chmod g+w, and tried saving again. Got the same "permission denied" error, but back in the terminal, I did 'ls -l' and saw that the file now had size 0. I had to chown the file and save again before it would work.

Change History (3)

comment:1 Changed 11 years ago by dkocher

  • Milestone set to 2.7.2
  • Severity changed from normal to critical
  • Status changed from new to assigned

comment:2 Changed 11 years ago by dkocher

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 11 years ago by henrrrik

The problem is indeed fixed in 2.7.2 (2649). Great!

Note: See TracTickets for help on using tickets.
swiss made software