Cyberduck Mountain Duck CLI

#9747 closed defect (worksforme)

Listing directory failed with error request signature we calculated does not match the signature you provided

Reported by: dmwhitaker87 Owned by:
Priority: high Milestone: 5.3
Component: s3 Version: 5.2
Severity: major Keywords:
Cc: Architecture:
Platform: Mac OS X 10.11

Description (last modified by dkocher)

While using Cyberduck on two of my macs, I occasionally receive the message at the bottom. It is sporadic with which folders it won't open. My team and I successfully use Cyberduck on multiple devices to access those same directories, so it appears to be the configuration of Cyberduck on these two devices, though for the life of me I cannot find out what is difference on this one. I uninstall and reinstall, and have the same problem. Although the error says it has something to do with my "web hosting provider," I have no indication that is the case, since others on my team do not have this issue.

My job is primarily dependent on my ability to access these files. Any assistance you can offer would be greatly appreciated.

The error is:

Listing director (directory name) failed.
The request signature we calculated does not match the signature you provided. Check your key and signing method. Please contact your web hosting service provider for assistance.

Attachments (1)

Screen Shot 2016-11-02 at 10.46.25 AM.png (30.3 KB) - added by dmwhitaker87 on Nov 2, 2016 at 5:33:46 PM.

Download all attachments as: .zip

Change History (11)

comment:1 Changed on Nov 8, 2016 at 3:51:34 PM by dkocher

  • Milestone set to 6.0
  • Summary changed from Listing directory failed to Listing directory failed with error request signature we calculated does not match the signature you provided

comment:3 Changed on Nov 8, 2016 at 3:52:01 PM by dkocher

  • Description modified (diff)

comment:4 Changed on Jan 10, 2017 at 11:54:40 AM by dkocher

Possibly related to #9793.

comment:5 Changed on Jan 11, 2017 at 8:33:37 AM by dkocher

  • Milestone changed from 6.0 to 5.3

Milestone renamed

comment:6 Changed on Jan 11, 2017 at 12:08:55 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

This might be caused by using AWS2 signature for authentication instead of the default AWS4. Please try to remove your configuration file from ~/Library/Preferences/ch.sudo.cyberduck.plist and relaunch Cyberduck.

comment:7 Changed on Jan 13, 2017 at 2:20:04 AM by dmwhitaker87

Unfortunately, this is not a fix. The problem recurred again within hours.

comment:8 Changed on Jan 13, 2017 at 2:21:00 AM by dmwhitaker87

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:9 Changed on Jan 13, 2017 at 8:26:20 AM by dkocher

Please post the transcript from the log drawer (⌘-L).

comment:10 Changed on Jan 16, 2017 at 1:30:57 PM by dkocher

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please reopen this issue if you can still reproduce with the current 5.3 snapshot build.

Note: See TracTickets for help on using tickets.
swiss made software