Cyberduck Mountain Duck CLI

#9753 closed defect (duplicate)

High CPU load after opening application

Reported by: HansDampf Owned by:
Priority: normal Milestone: 5.3
Component: core Version: 5.2
Severity: normal Keywords: height load after launch for a while
Cc: Architecture: Intel
Platform: Mac OS X 10.11

Description (last modified by dkocher)

Hi,

first off all thanks for the work and the app.

Its about the Version 5.2.2 and earlier after i update to macOS Sierra 10.12.X .

The issue is after i launch the app it starts to produce hight cpu load. And this behavior stops after some minutes. The App it self is working normal, but i cant stop the app normally. I have to force stopping the app during this load.

When im looking with dtruss what the process is doing it looks like this all the time(Without making anything in the app, just starting)

mprotect(0x105B43000, 0x1000, 0x0)		 = 0 0
psynch_cvsignal(0x7FAB62507468, 0x2C8000002C900, 0x2C800)		 = 257 0
psynch_cvwait(0x7FAB62507468, 0x2C8010002C900, 0x2C800)		 = 0 0
psynch_cvsignal(0x7FAB62508C68, 0x2C0000002C100, 0x2C000)		 = 257 0
psynch_cvwait(0x7FAB62508C68, 0x2C0010002C100, 0x2C000)		 = 0 0
psynch_cvsignal(0x7FAB62508068, 0x2C6000002C700, 0x2C600)		 = 257 0
psynch_cvwait(0x7FAB62508068, 0x2C6010002C700, 0x2C600)		 = 0 0
psynch_cvsignal(0x7FAB62506868, 0x2CE000002CF00, 0x2CE00)		 = 257 0
psynch_cvwait(0x7FAB62506868, 0x2CE010002CF00, 0x2CE00)		 = 0 0
psynch_cvsignal(0x7FAB62508068, 0x2C7000002C800, 0x2C700)		 = 257 0
psynch_cvwait(0x7FAB62508068, 0x2C7010002C800, 0x2C700)		 = 0 0
psynch_mutexdrop(0x7FAB62508028, 0x85B0000085C03, 0x85B00)		 = 0 0
psynch_mutexwait(0x7FAB62508028, 0x85A0000085C03, 0x85A00)		 = 547843 0
psynch_cvsignal(0x7FAB62507468, 0x2C9000002CA00, 0x2C900)		 = 257 0
psynch_cvwait(0x7FAB62507468, 0x2C9010002CA00, 0x2C900)		 = 0 0
psynch_cvsignal(0x7FAB6250A868, 0x12C0000012D00, 0x12C00)		 = 257 0
psynch_cvwait(0x7FAB6250A868, 0x12C0100012D00, 0x12C00)		 = 0 0
psynch_cvsignal(0x7FAB62508C68, 0x2C1000002C200, 0x2C100)		 = 257 0
psynch_cvwait(0x7FAB62508C68, 0x2C1010002C200, 0x2C100)		 = 0 0
psynch_cvsignal(0x7FAB62506868, 0x2CF000002D000, 0x2CF00)		 = 257 0
psynch_cvwait(0x7FAB62506868, 0x2CF010002D000, 0x2CF00)		 = 0 0
psynch_cvsignal(0x7FAB62508068, 0x2C8000002C900, 0x2C800)		 = 257 0
psynch_cvwait(0x7FAB62508068, 0x2C8010002C900, 0x2C800)		 = 0 0
mprotect(0x105B43000, 0x1000, 0x1)		 = 0 0
psynch_cvsignal(0x7FAB62507468, 0x2CA000002CB00, 0x2CA00)		 = 257 0
psynch_cvwait(0x7FAB62507468, 0x2CA010002CB00, 0x2CA00)		 = 0 0
psynch_cvsignal(0x7FAB62589868, 0x17D0000017E00, 0x17D00)		 = 257 0
psynch_cvwait(0x7FAB62589868, 0x17D0100017E00, 0x17D00)		 = 0 0
psynch_cvsignal(0x7FAB62508C68, 0x2C2000002C300, 0x2C200)		 = 257 0
psynch_cvwait(0x7FAB62508C68, 0x2C2010002C300, 0x2C200)		 = 0 0
gettimeofday(0x700001F8AAF8, 0x0, 0x0)		 = 0 0
psynch_cvsignal(0x7FAB62506868, 0x2D0000002D100, 0x2D000)		 = 257 0
psynch_cvwait(0x7FAB62506868, 0x2D0010002D100, 0x2D000)		 = 0 0
psynch_cvwait(0x7FAB62600C68, 0x100000100, 0x0)		 = -1 Err#316
gettimeofday(0x7000027A2C88, 0x0, 0x0)		 = 0 0

And so on and so on.

Is it known ? And is a thing what apple has to fix in the library ?

tanks & best

Change History (5)

comment:1 Changed on Nov 8, 2016 at 3:42:25 PM by dkocher

  • Description modified (diff)

comment:2 Changed on Nov 8, 2016 at 3:42:39 PM by dkocher

  • Summary changed from cpu hight load after launch to High CPU load after opening application

comment:3 Changed on Dec 11, 2016 at 12:11:01 PM by relume

Hello

We have the same problem, when starting up Cyberduck with a previous open File-Transfer Log-window or when opening the File-Transfer Log-window and the File-Transfer Log-list is very long. Cyberduck freezes for a while (up to 2 min) and then works for some instances until it refreshes the File-Transfer Log-window. We tried to delete the Cyberduck preferences and cache files, but it seems that pferences are cached by MacOS. So the only way to solve the problem is to debug the preferences file and/or the cache files from outside of the affected MacOS user-account. I think the ticket #9569 is related to the same problem.

best regards and many thanks for this very very helpful tool!

comment:4 Changed on Jan 10, 2017 at 10:58:22 AM by dkocher

  • Milestone set to 6.0
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate for #9569.

comment:5 Changed on Jan 11, 2017 at 8:33:37 AM by dkocher

  • Milestone changed from 6.0 to 5.3

Milestone renamed

Note: See TracTickets for help on using tickets.