Cyberduck Mountain Duck CLI

#9755 closed defect (thirdparty)

Malformed request during multipart upload

Reported by: ryanfarris Owned by:
Priority: normal Milestone: 5.3
Component: s3 Version: 5.2.2
Severity: critical Keywords:
Cc: Architecture: Intel
Platform:

Description (last modified by dkocher)

Hello,

I'm using Cyberduck against an s3 server we have built as part of our data service offering at Igneous Systems. When I attempt to issue a multipart upload using any object >=200MB, the upload hangs toward the end of the upload. Through request logging we can see this is actually due to a malformed request from Cyberduck:

request-out: POST /RMF-container//RMF-container/ice/Anaconda2-4.2.0-MacOSX-x86_64.pkg?uploadId=825e823b7f8abe4e912b4c6ce63e6934
Elapsed_Time: 2.467971ms
HTTP_Status_Code: 404
X-Content-Type-Options: nosniff
X-Amz-Request-Id: 0-16-9e2e6a2f177f772ea0b2221110e2069a
Content-Type: text/plain; charset=utf-8

Note the path is wrong as the bucket name is repeated twice. Because of this we can't find the upload and fail the request. The bucket name should be listed only once in the request.

Change History (3)

comment:1 Changed on Nov 7, 2016 at 9:43:28 PM by dkocher

  • Description modified (diff)

comment:2 Changed on Nov 7, 2016 at 9:45:48 PM by dkocher

  • Milestone set to 6.0
  • Resolution set to thirdparty
  • Status changed from new to closed

The issue is caused by a malformed reply to the initiate multipart upload request. The Key in InitiateMultipartUploadResult should not include the bucket name. Refer to http://docs.aws.amazon.com/AmazonS3/latest/API/mpUploadInitiate.html#mpUploadInitiate-responses

comment:3 Changed on Jan 11, 2017 at 8:33:37 AM by dkocher

  • Milestone changed from 6.0 to 5.3

Milestone renamed

Note: See TracTickets for help on using tickets.