Cyberduck Mountain Duck CLI

#9760 reopened defect

Download failure when filename or directory contains # character

Reported by: ivoryfurball Owned by: yla
Priority: low Milestone: 7.0
Component: webdav Version: 6.9.0
Severity: normal Keywords: hashtag, pound sign, #, number sign, export, "save as"
Cc: ginny.prescott@…, ivoryfurball@… Architecture:
Platform: Windows 10

Description

Unable to export via WebDAV HTTP/SSL if content contains hashtag (#) - repeated attempts to export/Download files from a server fail if any of the target files contain a hashtag in the filename, sometimes it's just a few files & I can find and change the file name manually then re-try the export/download & it works fine, but other times there may be hundreds of "#" in the collection of filenames, it's too time consuming to find & change them all to re-try the export/download. Both Win7 & Win10 OS on both 32-bit & 64-bit machines.

Attachments (1)

Error when a file has a hashtag in its name.jpg (120.8 KB) - added by ivoryfurball on Jan 25, 2017 at 5:50:32 PM.

Download all attachments as: .zip

Change History (13)

comment:1 Changed on Nov 14, 2016 at 7:57:35 PM by dkocher

  • Summary changed from Unable to export via WebDAV HTTP/SSL if content contains hashtag (#) to Download failure when filename contains # character

Please post the transcript from the log drawer of the Transfers window. Choose ⌘-L on Mac or right-click the toolbar from the Transfers window and choose Log on Windows

comment:2 Changed on Jan 10, 2017 at 8:39:21 AM by dkocher

  • Milestone set to 6.0
  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this issue with Apache/2.2.31 (Amazon) DAV/2.

comment:3 Changed on Jan 11, 2017 at 8:33:37 AM by dkocher

  • Milestone changed from 6.0 to 5.3

Milestone renamed

comment:4 Changed on Apr 10, 2017 at 5:54:38 PM by ivoryfurball

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Still chokes every time one of the exporting files contains a # character in the file name; Win7 & Win10 via WebDAV HTTP/SSL. Not resolved. Version 5.3.7 (23440) I can be exporting 1000 files but if any one of them contains a # in the filename, the whole download will fail.

comment:5 Changed on Apr 11, 2017 at 1:01:04 PM by dkocher

  • Milestone changed from 5.3 to 6.0

comment:6 Changed on Apr 17, 2017 at 7:12:39 PM by dkocher

  • Component changed from webdav to core
  • Owner set to yla
  • Platform changed from Windows 7 to Windows 10
  • Status changed from reopened to new

comment:7 Changed on May 5, 2017 at 1:45:11 PM by dkocher

  • Milestone changed from 6.0 to 7.0

Ticket retargeted after milestone closed

comment:8 Changed on Feb 11, 2019 at 7:15:46 PM by ivoryfurball

  • Cc ivoryfurball@… added
  • Component changed from core to webdav
  • Summary changed from Download failure when filename contains # character to Download failure when filename OR FOLDER contains # character
  • Version changed from 5.2.2 to 6.9.0

Update: it's been a few years now, but still struggling with the same problem when encountering files with a # character in the filename. Error generated: "Download FILENAME failed. Unexpected Response (404 Not found). Please contact your web hosting service provider for assistance" Files that have a # in the filename are not fully downloaded, the name just stops at the # character, omitting the remainder of the path, including the type extension such that the file cannot be opened at all without an associated program extension.

comment:9 Changed on Feb 15, 2019 at 1:45:10 PM by dkocher

  • Summary changed from Download failure when filename OR FOLDER contains # character to Download failure when filename or directory contains # character

comment:10 Changed on May 3, 2019 at 9:49:48 PM by ivoryfurball

Will this ever be fixed? I literally instruct all of my users NOT to use the # symbols in their uploaded files or folders even if Microsoft allows it because I can't extract it later with Cyberduck. That's 2k people pissed off at me because they can't use a # symbol to denote a "Change Order # XXXX" or a "Meeting Minutes # XXX" - I even tried to open a support ticket with the software that we use Cyberduck with (e-Builder) and this was their response:

Ginny – I think your true crusade is on the Cyberduck side of the equation. E-Builder enforces the “reserved characters” that Microsoft determines, and # is not on that list. Cyberduck really should be handling that character without problem because it is an acceptable character.

*sigh*

comment:11 Changed on May 31, 2019 at 3:02:33 PM by dkocher

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this error with the current snapshot build. Please reopen with server details if still an issue.

comment:12 Changed on Dec 2, 2019 at 6:29:20 PM by ivoryfurball

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Server details: docs.e-builder.net WebDav , port 443

Account credentials need to be assigned to use this specific application, but really no other application anywhere else in the world of all the people who use Cyberduck globally to move content has issue when there's a "#" symbol in their file/folder names? Syncovery has the same issue with files that have # symbol in them, but Cyberduck is way friendlier/easier in every way to use, we love it aside from this one quirk.

Note: See TracTickets for help on using tickets.
swiss made software